Issue 112829 - Copy & paste of OLE object to Gimp fails with error message
Summary: Copy & paste of OLE object to Gimp fails with error message
Status: REOPENED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.0
Hardware: Other All
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-01 00:35 UTC by plexi
Modified: 2014-02-27 21:28 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.1
Developer Difficulty: ---


Attachments
pasted graph (13.67 KB, application/vnd.oasis.opendocument.text)
2013-07-06 19:11 UTC, Edwin Sharp
no flags Details
original data (13.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-06 19:12 UTC, Edwin Sharp
no flags Details
auxilliary file (6.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-06 19:14 UTC, Edwin Sharp
no flags Details
File 1 no password (7.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-09 19:17 UTC, Edwin Sharp
no flags Details
Sample Document (44.39 KB, application/vnd.sun.xml.calc)
2014-01-02 07:18 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description plexi 2010-07-01 00:35:07 UTC
This bug happens in Ubuntu Lucid, with OOo 3.2

Repro:
1. Fire up OOo Calc
2. Type in a few numbers
3. Insert a bar chart showing those numbers
4. Select the bar chart
5. Copy it to the clipboard
6. Try to paste it into e.g. GIMP

Result:
GIMP says there's nothing on the clipboard and refuses to paste.

Expected result:
I should be able to paste a bitmap of my chart into GIMP and save it from there. 
GNumeric can do this even, I expect this to "just work".
Comment 1 Edwin Sharp 2013-07-06 18:56:48 UTC
Can paste graph in Paint using Rev. 1499775 Win 7.

If GIMP refuses to paste it has a problem.

Closed this bug as FIXED and not as NOTABUG because till recently graph pasted incorrectly even within suite showing only area without data.
Comment 2 Edwin Sharp 2013-07-06 19:04:04 UTC
My conclusion was premature.
Values are incorrect.
Comment 3 Edwin Sharp 2013-07-06 19:11:53 UTC
Created attachment 81016 [details]
pasted graph

pasted graph with wrong numerical values
Comment 4 Edwin Sharp 2013-07-06 19:12:20 UTC
Created attachment 81017 [details]
original data
Comment 5 Edwin Sharp 2013-07-06 19:14:18 UTC
Created attachment 81018 [details]
auxilliary file

auxiliary file needed due to vlookup function in original data
Comment 6 Armin Le Grand 2013-07-09 13:49:48 UTC
ALG: Opening file from comment 4 asks for updating links to another file (probably file from comment 5), requires password for file 'File2.ods', please add password.
The original task is about getting a *bitmap* image in an external paint program when copy/pasting a chart, not about copying the chart between apps of AOO4.0.
Copy/Pasting between apps in AOO4.0 is #120559#.

To check for copy/paste between AOO4.0 apps I will need the password for file 'File2.ods'.

Copy/pasting with gimp is not reliable; I found myself some time ago that the clipboard support of gimp is varying from version to version, thus it is better to check with various graphic apps.

On win I checked:
- copy/pasting from Writer /test file from comment 3) to paint.net -> works well
- to gimp2.8 -> not directly from Writer, but as workaround it's possible to copy/paste to Draw/Impress, convert to bitmap there and copy/paste to Gimp.
- to MyPaint: Same as for Gimp.

Original bug is questionable: Is it intended to copy a chart from Writer to an external pixel program directly? It is possible from Draw/Impress directly, all others should get the chart first copied to Draw/Impress as workaround.
Comment 7 Armin Le Grand 2013-07-09 14:58:10 UTC
ALG: Using Paint from win7 directly (as reference for clipboard functionality): The chart can be directly copied from all apps (also checked that copying the chart from test doc from comment 3 to all other apps, works well without data loss). The question for other external paint programs is more what clipboard formats these support, AOO offers something useful in all cases.
Comment 8 Edwin Sharp 2013-07-09 15:34:38 UTC
password is scooter.
File is related to some other bug I reviewed, sorry.
Comment 9 Armin Le Grand 2013-07-09 16:11:47 UTC
ALG: Hi Edwin, thanks for the password, but - it does not work. It says 'the password is incorrect'. Please check with 'File1.ods'.
Comment 10 Edwin Sharp 2013-07-09 16:37:13 UTC
I check and recheck - scooter, like the famous German band :)
Comment 11 Armin Le Grand 2013-07-09 16:41:48 UTC
ALG: Edwin, I may be too lame to type that, but I cannot open 'File1.ods' from comment 4 using 'scooter' as password. What's going on ;-)
Comment 12 Edwin Sharp 2013-07-09 19:17:47 UTC
Created attachment 81046 [details]
File 1 no password

This is strange...
Only scooter opens the file.
This attachment is just save as without password.
Comment 13 Armin Le Grand 2013-07-10 09:14:18 UTC
ALG: Thanks Edwin, can open now. Still strange, and after load and update, the value '13' is not shown in the chart. After activating and toggling dataRanges/DataSeriesInRows and back to Columns it gets visible, a refresh problem...?

copy/pasting in calc or to new app does not lose any data (thus #120559# was successful), but changes the data labels on the Y-Axis from simple values to date format. Is that what you mean with 'wrong numerical values'? If yes, please check if we have a task for this or create a new one. This can also be reproduced by creating a chart as this newly just with fixed values and copy/pasting it.
- Does not happen in OOo3.3
- Does not happen in OOo3.2

Back to this task: I checked on mac; I do not know what app to use as standard regarding clipboard implementation, but it can be copied to some apps. The workaround converting to graphic is always possible.
Comment 14 Edwin Sharp 2013-07-10 09:35:57 UTC
(In reply to Armin Le Grand from comment #13)
> Is that what you mean with 'wrong numerical values'? If yes,
> please check if we have a task for this or create a new one. 

Yes - opened bug 122714
Comment 15 Rainer Bielefeld 2014-01-02 06:07:08 UTC
Additional Info:
---------------
(a) The original report was concerning a copy/paste problem of Charts to Gimp. 
    That never worked for me with OOo back to 1.1.5
(b) As Edwin stated, that might be a Gimp problem. 
(c) But from the same sample document opened with I can Copy / Paste the chart 
    object to Gimp
(c1) From Gnumeric
(c2) From SoftMaker FreeOffice (using an .xls)
(c3) Even from Lotus Symphony Release 3.0.1 Revision 20120110.2000
     Copy / Paste of Chart to Gimp works fine. 
     So this might be an OOo / AOO problem?
(d)  Already reproducible with  Pre-3.4.0 (OOo 1.1.5), but because of crippled  
     Version selector (Bug 123063) no useful info can be contributed
(d) all the same when I try to copy / paste a chart object from Writer to
    Gimp
(e) but the problem Copy/Paste to gimp is not limited to Chart objects. Fails 
    with same error message for copy / paste from AOO 4.0.1
(e1) Formula object from Writer, Calc, Draw
(e2) Spreadsheet object from writer (others not tested

I will obsolete all old Attachmets because they are only worrying hand do not have to do anything with the original report.
Comment 16 Rainer Bielefeld 2014-01-02 07:18:36 UTC
Created attachment 82198 [details]
Sample Document

Steps how to reproduce with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions

0. Launch Gimp
1. From AOO Start Center open attached sample document
2. Click Chart (or Formula)
3. <control+c> for Copy
4. Switch to Gimp
5. <Control+v> for paste
   (Alternatively: menu 'Edit -> Paste As -> New picture)
  Expected: new picture with chart image
  Actual: Error message: "Clipboard does not contain picture ..."            :-(
Comment 17 Armin Le Grand 2014-02-27 21:28:10 UTC
Works with 'Paint' and 'Paint.NET', but not with 'MyPaint' or 'Gimp2.8'. This shows that AOO offers (bitmap?) data that can be consumed. Need to check deeper...