Issue 112845 - Shape formatting is reset to default after copy-paste (OODraw)
Shape formatting is reset to default after copy-paste (OODraw)
Product: Draw
Classification: Application
Component: formatting
PC Windows XP
: P2 Trivial (vote)
: ---
Assigned To: AOO issues mailing list
: needmoreinfo
Depends on:
  Show dependency treegraph
Reported: 2010-07-01 13:42 UTC by lambda_belka
Modified: 2013-02-07 22:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

file with shapes, whose formatting gets reset to default by copying-pasting (20.69 KB, text/plain)
2010-07-01 13:45 UTC, lambda_belka
no flags Details
screenshot (329.52 KB, image/jpeg)
2010-07-01 14:11 UTC, wolframgarten
no flags Details
formatting reset result (50.55 KB, image/gif)
2010-07-01 14:27 UTC, lambda_belka
no flags Details
Example of copy/paste distortion in draw (27.46 KB, image/png)
2011-05-29 02:23 UTC, alkaatibu
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lambda_belka 2010-07-01 13:42:28 UTC
The issue appeared after updating OO to v3.2.1 Can't remember what the previous
version was, but most probably v3.1.1.
I will attach a drawing file to the issue. To observe defect simply do
(1) ctrl-a (select all) 
(2) ctrl-v (paste)
, and see how formatting of some shapes is reset to default.
No idea how to reproduce such corrupted drawing.
In fact, I have a lot of models corrupted by this bug. I would be very thankful,
if anybody suggested any way to repair my drawings - should it be macro or any
other way. Will the downgrade help?..
Comment 1 lambda_belka 2010-07-01 13:45:14 UTC
Created attachment 70336 [details]
file with shapes, whose formatting gets reset to default by copying-pasting
Comment 2 wolframgarten 2010-07-01 14:07:59 UTC
Sorry, not reproducible.  Tested with DEV300_m84 and OOO3.2.1 . I think in your
description there is a ctrl-c missing? Otherwise nothing would happen. Attaching
Comment 3 wolframgarten 2010-07-01 14:11:26 UTC
Created attachment 70339 [details]
Comment 4 lambda_belka 2010-07-01 14:27:35 UTC
Created attachment 70340 [details]
formatting reset result
Comment 5 lambda_belka 2010-07-01 14:35:10 UTC
I rechecked the attachment - downloaded it and it still has same issue on my
system. It's strange that you are unable to reproduce it.
You are right - I forgot the ctrl-c step!)))) Sorry.

One more interesting detail: 
A feature I set up in options - [ctrl + mouse-click-on-shape + move mouse] =
[shape copying]. Similar feature works in MS Visio. Now when I do copy with this
method, it copies alright - all formattings are kept!
Probably different copy-paste methods are in use!!
Comment 6 alkaatibu 2011-05-29 02:11:44 UTC
I have noticed the same behavior as the original poster.

I am running LibreOffice 3.3.2 on Ubuntu 11.04. 

1) Save and open the following file from the Internet:

2) Start a new drawing file.

3) Copy a shape from Basic_Network_Shapes.odg.

4) Paste it into the new file. The pasted shape looks different from the copied shape. See attached image for the difference.

Can a developer reproduce this behavior? If so, what is causing it? Is there something wrong with the shape, or with a setting on my machine, or the application itself?
Comment 7 alkaatibu 2011-05-29 02:23:46 UTC
Created attachment 76568 [details]
Example of copy/paste distortion in draw
Comment 8 Armin Le Grand 2012-02-10 13:13:18 UTC
ALG: Probably double to #118772#
Comment 9 Rob Weir 2013-02-02 02:57:30 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the