Issue 113000 - letters get reversed with long paragraphs
Summary: letters get reversed with long paragraphs
Status: CLOSED WONT_FIX
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOO310m18
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2010-07-07 11:24 UTC by mousamjad
Modified: 2010-07-12 12:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Arabic appears in reverse order (9.83 KB, application/vnd.oasis.opendocument.text)
2010-07-07 12:58 UTC, munzirtaha
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mousamjad 2010-07-07 11:24:03 UTC
this problem appear when you write any paragraph without press Enter button (
AKA New Line button ) 
depend I think the RAM of each machine 
the write will be stop after some page 
I try in my computer stop after 26 pages , And try it in other computer stop
after page number 19
remember don't press Enter button during Enter text .. 


and there are other problem depend this problem in Arabic if you can't insert
any character .. 
put the Alignment from RTL (Right to left) to LTR (Left to Right) 
The Arabic letters will be c ..
Comment 1 eric.savary 2010-07-07 11:29:59 UTC
It seems you don't understand how this issue tracker system works.
This issue is a copy of issue 112997 which is itself a duplicate of issue 17171.

If different problems arise, file different issues.

Please read: http://qa.openoffice.org/issue_handling/basic_rules.html
Comment 2 eric.savary 2010-07-07 11:30:19 UTC
closed
Comment 3 munzirtaha 2010-07-07 12:55:50 UTC
@ es: this bug is not about long paragraphs not allowed it's about Arabic
letters being reversed with long paragraphs. I modified the summary and
attaching a sample document with some Arabic that's reversed. Delete the last
lines, and you would see Arabic is reversed.
Comment 4 munzirtaha 2010-07-07 12:58:14 UTC
Created attachment 70437 [details]
Arabic appears in reverse order
Comment 5 munzirtaha 2010-07-07 12:59:02 UTC
I tested with OOo in Maverick
Comment 6 eric.savary 2010-07-07 13:54:47 UTC
Ok, deleting one character of the last line reverses the characters.
But I ask myself: do we need to fix this?

1) the document contains only Arabic text but the writing direction is *LTR*, so
AFAIK incorrect when writing in Arabic.
Please correct if I'm wrong (I can't read Arabic) but the correct writing should
be what looks to me as:
"jiio ab"

and not as showing in LTR as:
"ba oiij"

Right?

If this is true, the characters reversing at last line switch from LTR to RTL so
actually find the correct writing.

2) This is not reproducible when the whole text is set to RTL from the start (so
a normal use)

3) This only happens for non typical 29 page long paragraphs: where is the user
case?

Sum up: an odd artifact happens in Arabic texts with non realistic huge
paragraphs and when the Arabic text direction has been set incorrectly.

So again my question: why should we fix what look like a pure theoretical
question and has no user case?
Comment 7 eric.savary 2010-07-09 12:54:16 UTC
As explained. No need to invest time in such problems.
Comment 8 eric.savary 2010-07-09 12:54:28 UTC
Closed
Comment 9 munzirtaha 2010-07-09 15:48:37 UTC
The bug is serious and practical. I just copied long English paragraphs from
well-known novels and the English words get reversed. e.g copy Episode 18 -
Penelope from
http://www.online-literature.com/james_joyce/ulysses/18/
Comment 10 eric.savary 2010-07-09 18:05:08 UTC
It is still the same problem: (very) long paragraphs causes this (which I cannot
reproduce with the last sample but it does not matter) and such long paragraphs
are a totally marginal usage.

I don't deny the fact this causes problems. I just say those problems are not
that high that we invest resources we don't have to fix them.
Comment 11 eric.savary 2010-07-09 18:05:20 UTC
closed
Comment 12 munzirtaha 2010-07-09 21:16:36 UTC
Since you don't deny the fact that it causes problems, then please leave the bug
open till you have resources or till some one willing to fix it volunteers for
the task.

The reporter of the bug among others are attending a basic training in FOSS I am
delivering and testing OOo and comparing it with other alternatives and we don't
want them to get the impression that we close valid bugs just because we don't
have the resources now. Leter on, may be we can donate some money or resources
to fix those bugs as a side project.
Comment 13 michael.ruess 2010-07-12 12:44:43 UTC
This issue can be reopened, when a developer having resources to fix this has
been found.
Thanks for your patience.