Issue 113228 - OOO330_m1: smoketest fails
Summary: OOO330_m1: smoketest fails
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOO330m1
Hardware: All All
: P1 (highest) Trivial (vote)
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-18 19:14 UTC by rene
Modified: 2010-07-19 15:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rene 2010-07-18 19:14:08 UTC
See last comment in http://www.openoffice.org/issues/show_bug.cgi?id=112758.
Build was a vanilla one with --disable-odk:

------- Additional comments from rene Sun Jul 18 17:11:51 +0000 2010 -------

I can confirm this ONLY for X11 (i.e. xvfb-run, but see below), NOT for using
svp. In the second case I still get:

: &&    
LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}/home/rene/OpenOffice.org/OOO330_m1/smoketestoo_native/unxlngx6.pro/lib:/home/rene/OpenOffice.org/OOO330_m1/solver/330/unxlngx6.pro/lib
/home/rene/OpenOffice.org/OOO330_m1/solver/330/unxlngx6.pro/bin/cppunittester \
       
-env:UNO_SERVICES=file:///home/rene/OpenOffice.org/OOO330_m1/smoketestoo_native/./unxlngx6.pro/misc/smoketest/services.rdb
\
       
-env:UNO_TYPES=file:///home/rene/OpenOffice.org/OOO330_m1/solver/330/unxlngx6.pro/bin/types.rdb
\
       
-env:arg-soffice=path:/home/rene/OpenOffice.org/OOO330_m1/solver/330/unxlngx6.pro/installation/opt/openoffice.org3/program/soffice
-env:arg-user=./unxlngx6.pro/misc/smoketest/user \
        -env:arg-env=LD_LIBRARY_PATH"${LD_LIBRARY_PATH+=$LD_LIBRARY_PATH}"
./unxlngx6.pro/lib/libsmoketest.so -env:arg-doc=./unxlngx6.pro/bin/smoketestdoc.sxw
officeconnection.cxx:136:Assertion
Test name: N12_GLOBAL__N_14TestE::test
setUp() failed
- equality assertion failed
- Expected: 2
- Actual  : 0

officeconnection.cxx:163:Assertion
Test name: N12_GLOBAL__N_14TestE::test
tearDown() failed
- equality assertion failed
- Expected: 0
- Actual  : 77

Failures !!!
Run: 1   Failure total: 2   Failures: 2   Errors: 0
dmake:  Error code 1, while making 'cpptest'

though with no Java crash.

As many things outside of OOo using OOo use svp, I don't believe this is a good
sign ;)

(with xvfb-run it just "hangs", running under "normal" $DISPLAY says
"A general error occursed while accessing your central configuration").
Comment 1 Olaf Felka 2010-07-18 21:14:26 UTC
reassigned
Comment 2 Stephan Bergmann 2010-07-19 08:22:08 UTC
@rene:  The output indicates that soffice terminates upon startup with exit code
77, aka E_FATAL_ERROR (desktop/source/inc/exithelper.hxx), most probably from
FatalError in desktop/source/app/app.cxx.  It tries to display an sMessage there
in an error box; so please use a debugger or printf to read the message.

I could not reproduce this problem on unxlngi6.pro OOO330_m1 with no DISPLAY set
(which will cause VCL to resort to headless, AFAIU); building smoketestoo_native
succeeds.
Comment 3 rene 2010-07-19 08:36:03 UTC
sb: even if it is that, that is no reason to reassign it to me.
Comment 4 rene 2010-07-19 08:38:06 UTC
(and note I didn't try on unxlngi6, and won't do so for some time to come. My
main system is a amd64 one, so I - of course - try on unxlngx6)
Comment 5 Stephan Bergmann 2010-07-19 08:39:33 UTC
Rene, we apparently need your input here, so I thought it useful to pass the
issue back to you for now.  Feel free to assign it to me if you have a problem
with that.
Comment 6 Stephan Bergmann 2010-07-19 08:43:28 UTC
cannot reproduce on unxlngx6.pro OOO330_m1, either
Comment 7 rene 2010-07-19 09:00:45 UTC
> Rene, we apparently need your input here, so I thought it useful to pass the    
> issue back to you for now.  Feel free to assign it to me if you have a problem  
> with that.

OK, what do you  need?
Comment 8 Stephan Bergmann 2010-07-19 09:02:25 UTC
@rene, as I wrote in <#desc3>: "so please use a debugger or printf to read the
message."
Comment 9 rene 2010-07-19 15:28:45 UTC
MMh, I have a fear on why this happens... Setting to INVALID..

Note to self: Don't do changes in e.g. OOO330_m1 just for hg diff, as you surely
will forget about them when you actually build it.
Comment 10 Stephan Bergmann 2010-07-19 15:37:56 UTC
.