Issue 113400 - Maths brackets misformed in presentation mode
Summary: Maths brackets misformed in presentation mode
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 3.2
Hardware: Unknown Other OS
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: thb
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2010-07-24 20:29 UTC by cosine
Modified: 2010-09-22 09:43 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
presentation that shows bug (76.79 KB, text/plain)
2010-07-24 20:30 UTC, cosine
no flags Details
screenshot presentation output (56.14 KB, text/plain)
2010-07-25 11:26 UTC, cosine
no flags Details
Screenshot in editor (fine) (166.53 KB, text/plain)
2010-07-25 11:27 UTC, cosine
no flags Details
fix it (798 bytes, text/plain)
2010-08-06 12:32 UTC, dtardon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cosine 2010-07-24 20:29:52 UTC
THe attached file has some large brackets in an equation.
They display fine during editing and in PDF export, but
in presentation mode they are too large and misplaced.

THis is in linux FC13, on 3.2.0, 320m12.
Comment 1 cosine 2010-07-24 20:31:00 UTC
Created attachment 70803 [details]
presentation that shows bug
Comment 2 Rainer Bielefeld 2010-07-25 08:52:16 UTC
Corrected OS due to report.
NOT reproducible with "Ooo 3.1.1 WIN XP DE[OOO310m19 (Build 9420)]", "Ooo-Dev
3.2.0 multilingual version English UI WIN XP: [DEV300m67 (Build 9466)]"!
I am pretty sure that I saw an other issue concerning a presentation 

@cosine:
Please
- attach screenshots with comments
- contribute information concerning
  -- download source and localization of your OOo
  -- OOo settings
  -- your PC (graphic card, ...)
Comment 3 cosine 2010-07-25 11:26:28 UTC
Created attachment 70806 [details]
screenshot presentation output
Comment 4 cosine 2010-07-25 11:27:08 UTC
Created attachment 70807 [details]
Screenshot in editor (fine)
Comment 5 Rainer Bielefeld 2010-07-25 12:46:31 UTC
Linux or 3.2 specific? Can't confirm heavy damages from screenshot presentation
output.

@cosine:
can you please select correct mime types for your attachments?
Comment 6 jbf.faure 2010-07-25 14:07:11 UTC
I can't reproduce the problem with OOo 3.2.1 FR nor OOO330m1 under Linux /
Ubuntu 8.04.

Kind regards. JBF
Comment 7 Joe Smith 2010-07-25 20:38:57 UTC
Are you using the Fedora-packaged OOo, or have you installed the packages
downloaded from OO.org?

If you're not sure, look at Help > About OOo: the Fedora-packaged OOo includes
the words "... created by Red Hat...".

I do not see the problem running the OO.org 3.2.1 build on F13

I do see the problem if I view it using the Fedora build (3.2).

Issues specific to the Fedora builds should be reported through
https://bugzilla.redhat.com/bugzilla/index.cgi

See http://fedoraproject.org/wiki/BugsAndFeatureRequests to get started.
Comment 8 cosine 2010-07-25 21:54:10 UTC
This is indeed the Fedora build.
I will report it there.

Thanks for the quick resolution.
Comment 9 Rainer Bielefeld 2010-07-26 05:05:00 UTC
Invalid due to latest comments
Comment 10 Rainer Bielefeld 2010-07-26 05:05:31 UTC
@cosine:
Thank you for your attention.
Comment 11 dtardon 2010-07-26 08:03:17 UTC
I see it on DEV300_m85.
Comment 12 dtardon 2010-08-06 12:32:25 UTC
Created attachment 70986 [details]
fix it
Comment 13 dtardon 2010-08-06 12:36:46 UTC
The problem is only visible with cairo impl. of canvas (i.e.
Tools->Options->OpenOffice.org->View, check Use hardware antialiasing). It's
been here since integration of CWS cairocanvastext01.

dtardon->thb: canvas is yours, right?
Comment 14 thb 2010-08-06 13:04:50 UTC
@dtardon: cool, good catch - any cws at hand we can put this into? @pl/@cmc or
you guys?
Comment 15 dtardon 2010-08-06 13:13:37 UTC
dtardon->thb: not me, but cmc has one that is going to go on qa soonish
Comment 16 dtardon 2010-08-06 13:14:39 UTC
reassigning to cmc
Comment 17 caolanm 2010-08-06 13:27:10 UTC
committed to cmcfixes77 as
http://hg.services.openoffice.org/cws/cmcfixes77/rev/e08d3a985a67
Comment 18 caolanm 2010-08-06 13:28:02 UTC
please verify to sign off on this
Comment 19 thb 2010-08-06 16:45:00 UTC
Verified commit, thanks!
Comment 20 dtardon 2010-08-28 16:00:18 UTC
integrated in DEV300_m87