Issue 113433 - crash while executing unoapi tests in toolkit
Summary: crash while executing unoapi tests in toolkit
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m84
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: Stephan Bergmann
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-26 15:42 UTC by philipp.lohmann
Modified: 2010-07-28 12:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample stack (2.95 KB, text/plain)
2010-07-26 15:44 UTC, philipp.lohmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description philipp.lohmann 2010-07-26 15:42:43 UTC
While trying to reproduce the problem detailed in issue 111113 I consistenly got
crashes with the attached stack or similar. The stack always happened during the
execution of a timer and crashed somewhere in java downstack of the
"attach_current_thread" function. This happened to me most often when using
vcl's gtk plugin (which you get on gnome desktops), but also happens with the
generic plugin; the difference in frequency would seem to be due to different
timing in gtk and generic case. It was not a specific test of the run that would
cause a crash, this seems to happen basically anytime.

Could you please have a look at this.
Comment 1 philipp.lohmann 2010-07-26 15:44:57 UTC
Created attachment 70825 [details]
sample stack
Comment 2 philipp.lohmann 2010-07-28 12:47:27 UTC
this was apparently a user error (not using the script, therefore
LD_LIBRARY_PATH was not set correctly for java).

Sorry for the noise.
Comment 3 philipp.lohmann 2010-07-28 12:47:48 UTC
closing