Issue 113476 - Printing multiple files from WinExplorer at once mkaes OOo unusable
Summary: Printing multiple files from WinExplorer at once mkaes OOo unusable
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.2.1
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2010-07-27 20:20 UTC by skybeam
Modified: 2013-08-07 15:31 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description skybeam 2010-07-27 20:20:51 UTC
The problem has been described on the forums already. See here:
and here:

Always when multiple documents (no matter if spreadsheet or word processor
files) are selected, then right-clicked and "print" is chosen then only one
document is printed. The Windows task manager will show then as many soffice.bin
and soffice.exe processes as documents selected. For example selecting 3
documents and trying to print them will open 6 processes (3x soffice.bin and 3x
soffice.exe). All hanging indefinitely.

There is no OOo window shown at all and processes seem to refuse shutdown
signals when the user tries to log off so even logoff and shutdown is blocked.
Users not familiar with the task manager will be unable to close down all
processes manually in order to be able to continue working.
While in this state (any soffice.bin and/or soffice.exe process running) it is
impossible to open up any other OpenOffice application.

This is especially annoying if the user clicked many documents (e.g. clicking 30
documents will create 60 processes which have to be killed individually via task

How to reproduce:
1. Create any ODF document
2. Create two copies of the document
3. Select all three ODF documents
4. Right-click the documents selected and chose "print" from the context-menu
5. Open Task Manager to see 6 soffice.bin/soffice.exe processes running

I guess it might be related to the "instance detection" feature of OpenOffice
but I was unable to disable it (allowing multiple instances).

No clean work-around known to me.
I was trying to create a send-to script called "print in OOo.cmd" which passes
all parameters to "soffice.exe -p %*". Unfortunately then a limit of Microsoft
applies which limits the number of arguments to 20. So printing more than 20
documents in one batch is impossible (my customer wants to print about 35).
Moreover if one already tried the right-click->print action then even the
send-to trick will not work any more due to already blocking
soffice.bin/soffice.exe processes. Asking an unexperienced user to reboot will
not work either since the PC will hang at reboot :-( so the only way is to ask
for a system reset which is dangerous to do without clean shutdown.
Comment 1 skybeam 2010-07-27 20:25:30 UTC
I am sorry, tried to put everything within the firs post but forgot that I spent
quite some time to reproduce the issue. It can be reproduced also on Windows 7
and on all machines I am working on (Windows XP x86 and Windows 7 x64).

I also tried to figure out since when it occurs which might help finding the
faulty code. I first noticed the issue in OOo 3.2.1 but it also exists in 3.2.1.
In version 3.1.1 all files selected will print and OOo seems to work properly
but after printing there is one pair of soffice.bin/soffice.exe left in the task
manager which does not terminate on its own.
Comment 2 Olaf Felka 2010-07-28 07:10:03 UTC
Please have a look.
Comment 3 michael.ruess 2010-07-28 09:30:23 UTC
MRU->PL: could reproduce this on Win7. Select e.g. three Writer documents in
WinExplorer, print these via context menu in Explorer -> only one will be
printed, for each a process is started and one will only be able to use OOo
again when these processes have been killed manually.
Comment 4 Oliver Brinzing 2010-07-28 17:18:14 UTC
Comment 5 philipp.lohmann 2010-08-19 12:02:12 UTC
@cd: this seems to be a framework problem; the debugger tells me that all three
soffice.bin processes wait for confirmation in
desktop/source/app/officeipcthread.cxx line 567 (in pThread->
Which one of them shouldn't be.

Interestingly enough sometimes one document gets printed before this deadlock.
Comment 6 eymux2009 2010-10-18 12:17:29 UTC
This seems to be a duplicate of issue 71417.
Comment 7 Martin Hollmichel 2011-03-15 21:02:23 UTC
set target to 3.x since not release relevant for 3.4 release.