Issue 113496 - UI Language switch based on glibc locale
Summary: UI Language switch based on glibc locale
Status: RESOLVED DUPLICATE of issue 103411
Alias: None
Product: Internationalization
Classification: Code
Component: i18npool (show other issues)
Version: current
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on: 103411
Blocks:
  Show dependency tree
 
Reported: 2010-07-28 14:33 UTC by grakic
Modified: 2020-02-10 14:54 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description grakic 2010-07-28 14:33:27 UTC
Issue 111003 provided support for using glibc locale modifiers to set OOo 
default locale and document language but lack support for UI switching.

When started with sr_RS@latin document language gets switched to Serbian Latin 
but English stays as default UI language even Serbian Latin (sh) language pack 
is installed.

If one switch to Serbian Latin manually, presented UI shows "Default - Serbian 
Latin" (Podrazumevano - srpski latinicom) in the UI lang list box but after 
selecting this option, it goes unexpectedly back to English.
Comment 1 ooo 2010-07-28 19:19:05 UTC
My guess (though totally unproven) is that the LocaleBackend code interferes,
handling things more simplistically. One more reason to merge these things, see
also issue 103411.

Assigning to spare time account.
Comment 2 Marcus 2017-05-20 11:35:16 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 3 oooforum (fr) 2020-02-10 14:54:10 UTC
.

*** This issue has been marked as a duplicate of issue 103411 ***