Issue 113573 - Default format does not reset numbering
Summary: Default format does not reset numbering
Status: CLOSED DUPLICATE of issue 10610
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-01 21:14 UTC by tab
Modified: 2010-08-03 13:17 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
file with First Line Indent para (10.27 KB, text/plain)
2010-08-01 21:17 UTC, tab
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tab 2010-08-01 21:14:15 UTC
This came from the Forum, where some arcane explanations about lists were given,
but left open the question: why does 'default formatting' (^m) not reset the
numbering, if the default format specifies 'none'?
In FirstLin.odt, right-click 'aaa', or click Format>Parag:
Indents&Spacing.FirstLineIndent=0.25: wrong. Outline&Numbering: Numbering3:
wrong. 'aaa' is supposed to be of style FirstLineIndent, but it's not; hitting
^m (default formatting) does not help.
Comment 1 tab 2010-08-01 21:17:00 UTC
Created attachment 70914 [details]
file with First Line Indent para
Comment 2 eric.savary 2010-08-01 22:24:22 UTC
The help says:
"Default Formatting

Removes direct formatting and formatting by character styles from the selection.
Direct formatting is formatting that you applied without using styles, such as
setting bold typeface by clicking the Bold icon."

As you are using styles, the formatting is not reset.

Comment 3 eric.savary 2010-08-01 22:24:34 UTC
closed
Comment 4 tab 2010-08-02 23:27:04 UTC
OK. This behaviour fits the definition. But it's so counter-intuitive that even
a Forum moderator (Hagar de l'est) writes: "This is a bug IMHO. It has always
existed I think. But 3.2.1 is worse at resetting the defaults of a paragraph."
   So, there may be an enhancement: reset completely a style by:
** double-clicking the style in the stylist --that's what the average user
expects; double-clicking does not imply 'direct formatting only';
** or by hitting ^m twice: The first time, it just 'removes direct formatting
and ...'; the 2nd time, it also resets changes done by styles. 
Comment 5 michael.ruess 2010-08-03 13:16:42 UTC
Issue 10610 describes the same problem.

*** This issue has been marked as a duplicate of 10610 ***
Comment 6 michael.ruess 2010-08-03 13:17:12 UTC
closing duplicate.