Issue 113642 - Bordering the cells over writes the text
Summary: Bordering the cells over writes the text
Status: CLOSED DUPLICATE of issue 122956
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-04 10:49 UTC by vijay_zither
Modified: 2017-05-20 09:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
borders over writes text passing thru cell (3.40 KB, application/pdf)
2010-08-04 10:51 UTC, vijay_zither
no flags Details
I have attached here the file depicting the problem i have mentioned above. (6.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-01-15 20:05 UTC, hajidon
no flags Details
Uploaded screenshot depicting actual(Open Office Calc) and expected (MS Excel) behaviors (87.87 KB, image/jpeg)
2011-01-24 00:58 UTC, rossi143
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vijay_zither 2010-08-04 10:49:57 UTC
When text passes through cells and borders were applied, the border lines over 
writes the text which should not be.

Thanks

Vijay
Comment 1 vijay_zither 2010-08-04 10:51:04 UTC
Created attachment 70949 [details]
borders over writes text passing thru cell
Comment 2 Marcus 2010-08-04 11:12:35 UTC
not a P1
Comment 3 hajidon 2011-01-15 20:00:22 UTC
Hi,
I have faced the same problem with OOo_3.2.1_Win_x86_install-wJRE_en-US.exe. I 
am using DELL N5010 notebook. When I write text on the box it is overwritten by 
the border lines and if you make the border lines bold.i.e. increase the style 
of the border line then some characters become unreadable. To replicate it 
create a new spread sheet and write a line whose length exceeds the table cells 
width then select that cell and right click on it and select format cells and 
then after click on the border tab increase the line style to 2.50 pt and select 
the 4th option under line arrangement. i.e.  set outer border and all inner 
lines.
I am also attaching here the file depicting the same problem.
Regards,
hajidon
Comment 4 hajidon 2011-01-15 20:05:08 UTC
Created attachment 75569 [details]
I have attached here the file depicting the problem i have mentioned above.
Comment 5 hajidon 2011-01-15 20:33:00 UTC
I am using windows as operating system.
Comment 6 rossi143 2011-01-23 14:39:25 UTC
I was able to replicate the problem using the following test environment:
Open Office 3.2.1 Build: 9502
OS: Windows 7 64 bit.

Steps to reproduce:

1. Open a new spreadsheet document in open office calc.

2. Change the formatting of a cell by performing the following steps:
a)Right Click on the header(A,B,C,D, ...), choose "Format cells"
b)Click on the Borders tab
c)Choose the second last option(Set outer border and All inner lines) under Line 
arrangement
d)Set style under Line option, it is easier to identify the problem if the line 
is considerably thick.

3. Type in one of the cells formatted in step2 such that the length of the text 
inserted exceeds the width of the cell. Border of the cell will overlap the 
text, making a few characters unreadable.
Comment 7 rollepmt 2011-01-23 17:35:54 UTC
I was also able to replicate the problem using the following test environments:

Open Office 3.2.1 Build: 9502
OS: Windows 7 Ultimate (32-bit)

Open Office 3.2.1 Build: 9502
OS: Mac OS X Version 10.6.5

Steps to Reproduce:

1. Open a new spreadsheet in Calc.

2. Before or after entering text in a cell that exceeds the cell width for that 
column, Right click (in Windows, or hold Control and then click for Mac) the 
respective row or column header and select "Format Cells...".

3. Click on the "Borders" tab.

4. Under "Line arrangement", any border option (with the exception of the 
default "Set No Borders" option) can be selected.

5. Click OK. 

If text is already entered that spans longer than the cell width, the border 
that appears will overlap with the text. If no text is entered, entering text 
that is long enough will again cause an overlapping of text and border.

This occurs with every border option that involves a right border, and tests 
were done on empty cells (with the text being entered after) and on already-
filled cells within Calc on both operating systems. Line Style did not matter, 
although the issues (like rossi143 stated) are more apparent with thicker lines.

While this issue can be addressed by wrapping text (which can be achieved by 
selecting the "Alignment" tab when selecting "Format Cells"), it may be 
bothersome to users who are unaware of this feature.
Comment 8 rossi143 2011-01-24 00:58:57 UTC
Created attachment 75620 [details]
Uploaded screenshot depicting actual(Open Office Calc) and expected (MS Excel) behaviors
Comment 9 ahmed313 2011-01-24 05:45:29 UTC
I was able to replicate the bug:

The environment used for this replication is as follows:

Open Office 3.2.1 Build 9502
OS: Windows 7 Home Premium 64 bit

To reproduce this bug, please follow the steps below:

1. Open a Spreadsheet in Open Office Calc
2. Select a cell and write some text such that it spans longer then the cell 
width and enters the adjacent cell.
3. Select the cell and click on "format cell".
4. Select "border"
5. Apply a thick border on the cell

After the border has been applied, it will over lap the text. 

I have done tests on a 4(row) by 3(column) table in Open Office Calc. I have 
written text that spans at least 2 adjacent cells in different parts of the 
table. When I applied the inner and outer borders, they over wrote the text.

This problem can be very frustrating and may require the user to do a lot of 
changes in his spreadsheet, if he is not aware of this bug. Some user may write 
headings in there spreadsheets that span 3 to 4 adjacent cells. Applying a 
border to this would overwrite the text. 
Comment 10 amayem_cse73176 2011-01-26 15:06:15 UTC
I have reproduced the issue:

Two Environments:
Linux CentOS release 4.6 (Final) connected through X11 by an ssh -X command from
Mac OSX 10.5.8
Open Office 3.2.0, Build: 9483

and

Mac OSX 10.5.8
Open Office 3.2.1 Build 9502

Steps are as follows:

1. Click on File -> New -> Spreadsheet
2. Write in cell C4 "ABCDEFGHIJKLMNOP"
3. Press Ctrl+1 to get the format cells panel
4. Click on the 'Borders' tab
5. Under 'Line Arrangement' choose the second or third option
6. Under 'Style' choose '0.05 pt' or '5.00 pt' or '7.50 pt' or the last '9.00 pt'
7. click OK

All combinations for the choices above were tried i.e. issue was reproducible in all 8 cases

Additional Comment: As the border thickness increases the text is obscured from other areas as well 
such as the top, bottom and the left side. This is especiall apparent in the '7.50 pt' and last '9.00 pt' 
cases.

Is it a bug? I am not sure if this is really a bug. The program is simply doing as it was told, to put a 
border around the cell. It is the user's fault for not making sure the cell was big enough. When choosing 
a thick border style it is natural that somethings will be overwritten.
Comment 11 Edwin Sharp 2013-12-26 19:21:22 UTC
Duplicate bug.

*** This issue has been marked as a duplicate of issue 122956 ***