Issue 113765 - export to HTML doesnt generate Image Map to implement Hyperlinks
Summary: export to HTML doesnt generate Image Map to implement Hyperlinks
Status: UNCONFIRMED
Alias: None
Product: Draw
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2010-08-10 12:34 UTC by polyglotinc
Modified: 2017-01-25 09:33 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description polyglotinc 2010-08-10 12:34:15 UTC
1. Draw supports hyperlinks to be associated with objects in a drawing.
2. Draw supports export/save-as of drawing to HTML page(s).
3. Draw supports conversion of drawing to GIF,JPG,etc image.

So, why oh why doesn't Draw auto generate the Image Map(s) needed to
actually implement the hyperlinks in a simple export to HTML???

This is a very simple use case and an obvious solution to fix the problem.
Comment 1 wolframgarten 2010-08-10 14:42:03 UTC
Please give a step by step description. I am not sure if I understood the
problem completely. You are aware of the option to use edit/Image Map? Thanks in
advance.
Comment 2 polyglotinc 2010-08-10 16:13:20 UTC
The use case is simple:
1. Create a drawing, inserting various text and shape objects as desired
2. Select object and Insert->Hyperlink specifying target URL
   (repeat for various objects as desired)
3. Export drawing to HTML document via File->Export...

The hyperlinks in the drawing should have AUTOMATICALLY been implemented in the
HTML page(s) generated by export.  A typical implementation mechanism would be
Image Maps that reference the GIF/JPG/etc image generated by the export.

The point is that Draw already has all the info it needs to do this
automatically without some agonizing manual setup of ImageMaps (via a wizard
which itself always gives me General Error, General Input/Output Error).
Comment 3 wolframgarten 2010-08-11 07:57:31 UTC
Changing to enhancement. Reassigned.
Comment 4 Rob Weir 2013-02-02 03:00:15 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 5 -1 2017-01-25 09:33:30 UTC
I have the same issue ... It fails if more than one page exists .