Issue 113805 - forgets inheritance of styles
Summary: forgets inheritance of styles
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-11 14:48 UTC by calestyo
Modified: 2017-05-20 10:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description calestyo 2010-08-11 14:48:44 UTC
In impress, when changing the defaults styles (Default, Text, Text body, etc.)
so that they're linked and inherit properties from their parents.... any "links"
are forgotten as soon as the file is saved/loaded again.
Comment 1 calestyo 2010-08-16 12:46:48 UTC
This is _similar_ to issue #106642.
Comment 2 wolframgarten 2010-08-17 11:42:39 UTC
Duplicate.

*** This issue has been marked as a duplicate of 106642 ***
Comment 3 wolframgarten 2010-08-17 11:43:13 UTC
Closed.
Comment 4 calestyo 2010-08-17 18:08:19 UTC
#106642 speaks just about when opening in different clients, while here it
happens even in the same one...
Comment 5 wolframgarten 2010-08-18 10:19:18 UTC
Ok, please give a step by step description for reproducing this.
Comment 6 calestyo 2010-08-18 17:48:04 UTC
1) Create a new (empty) presentation.
2) You'll see a number of styles
3) Change to the "Styles for formatting graphical elements, including text objects."
4) Choose "Hierarchical" display in the styles navigator.
5) Select e.g. the style "Title 1" and chose "Modify" in the context-menu.
6) Select the "Organizer" tab.
7) Set "Linked with" to e.g. "Title".
8) Now you should see that "Title 1" is a sub-style of "Title".
9) Save the document. Close it. Reopen it (in ooimpress).
10) The specified inheritance is lost, an "Title 1" is again linked with "Default".
Comment 7 wolframgarten 2010-08-20 10:03:13 UTC
Ok, thanks. Reproducible. Reassigned.
Comment 8 clippka 2010-09-06 14:56:11 UTC
adapting target
Comment 9 oooforum (fr) 2010-09-13 14:49:41 UTC
Hello,

Try this:
1- in a ODG document, create a shape
2- call the stylist (F5) and create a dedicated style for this shape (change
background color)
3- copy this shape
4- open a new ODG document
5- paste the shape
Actual result: the dedicated style is lost and the shape is set to the default
style.
Expected result: the shape is pasted with same characteristics and the style
appears in the stylist.

Is this the same problem? 
Comment 10 clippka 2010-10-04 12:39:39 UTC
oooforum, no. This issue is about setting another parent style to pre defined
styles. Please submitt a new issue for your problem

This issue is fixed in cws impress201 for OOo 3.4

Problem was that the API did not allow change of parent style and style name for
predefined styles. I removed this limitation as it does not make any sense.
Comment 11 clippka 2010-10-07 10:33:32 UTC
verified in cws, back to qa
Comment 12 wolframgarten 2010-10-11 13:38:24 UTC
Verified in CWS.