Issue 113828 - zoom slider is triggered (Without Reason) during page horizontal scroll upon mouse button release
Summary: zoom slider is triggered (Without Reason) during page horizontal scroll upon ...
Status: CLOSED DUPLICATE of issue 116958
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOO310m19
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-12 08:35 UTC by richardbaxter
Modified: 2017-05-20 10:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description richardbaxter 2010-08-12 08:35:28 UTC
When holding mouse button down on horizontal scroll bar to perform a scroll, if
cursor is hovered over the zoom bar during the scrolling process, when the mouse
button is released to finish the horizontal scroll, a zoom is triggered (as if
the zoom bar had been in operation).

To replicate issue;
1. press left mouse button on horizontal scroll bar
2. perform horizontal scroll
3. while performing horizontal scroll, move the mouse cursor over the page zoom bar
4. release left mouse button
5. Note that the zoom bar has been activated upon mouse release.

This is a critical OpenOffice.org User Interface issue.

Cheers,

Richard
Comment 1 richardbaxter 2010-09-24 13:33:27 UTC
This issue also occurs in Writer (and I assume all Openoffice.org components)
Comment 2 richardbaxter 2010-09-24 13:40:08 UTC
Basically, all that needs changing here is for the zoom bar to be triggered upon
mouse button release ONLY when the mouse button is first pressed on the scroll
bar (and NOT when the mouse button is first pressed elsewhere, and happens to be
released when the cursor resides over the zoom bar).

(It might well be a bug with the coding of the zoom bar UI component, not
necessarily with how it has been implemented - but I have never looked at the
source code so would not know).

Cheers - NB I have corrected the priority given to this bug - I think it is P1,
or at the very least P2 - but feel free to change it.

 
Comment 3 Marcus 2010-09-24 14:55:23 UTC
although I can understand your impression as this is not nice, it's clearly not
a P1, please see here:
http://qa.openoffice.org/scdocs/ddIssues_EnterModify.html#priority
Comment 4 richardbaxter 2010-09-24 16:01:59 UTC
Cheers no problem
Comment 5 Edwin Sharp 2013-12-09 20:36:22 UTC
Duplicate of bug 116958.

*** This issue has been marked as a duplicate of issue 116958 ***