Issue 11409 - Use OS X Installer for X11 builds
Summary: Use OS X Installer for X11 builds
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.2
Hardware: Mac Mac OS X, all
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.x
Assignee: ericb
QA Contact: issues@installation
URL:
Keywords:
Depends on: 63630
Blocks:
  Show dependency tree
 
Reported: 2003-02-12 09:52 UTC by Unknown
Modified: 2008-06-06 15:18 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-02-12 09:52:15 UTC
Please use the Installer that comes with OS X. First of all, it automatically creates a receipt and secondly, it allows users to inspect the package via the command-line or via 3rd party utilities like "Pacifst" to find out what gets installed where before doing the actual installation.
Since the documentation does not mention what gets installed where and I couldn't "inspect" the package, either, I didn't even install OpenOffice -- as much as I'd have liked to.
Comment 1 Olaf Felka 2003-02-12 12:12:23 UTC
Hi Bettina,
I think this belongs to the plan to use native installer on all
supported platforms.
Comment 2 terryt 2004-05-23 04:36:46 UTC
The current OOo 1.1.x TechPreviews for Mac OS X 10.3.x produced by Kevin Hendricks 
use the Mac OS X Installer.

Ed Peterlin is also planning on using the Mac OS X Installer for the OOo 1.1.x release 
(soon).
Comment 3 shaunmcdonald131 2005-02-25 16:31:16 UTC
Avoid wrapping it in a zip file as you could get problems with BOMArchive helper due to permissions 
being lost. A disk image would be better.
Comment 4 nospam4obr 2005-11-28 21:35:25 UTC
We currently use a drag and dropt installation for 2.0.0, but will most likely
change (back) to the Apple installer for 2.0.2. 
Comment 5 nospam4obr 2006-03-20 13:09:15 UTC
set target.
Comment 6 jjmckenzie 2006-03-26 14:38:30 UTC
This is very much still a valid issue.  Added dependency to 63030 and 63630.

James
Comment 7 moxfox 2006-03-26 15:25:33 UTC
Even though this has been filed before, I'd say this is a duplicate of issue 63630
Comment 8 nospam4obr 2006-03-26 15:34:27 UTC
re-assigned.
Comment 9 jjmckenzie 2006-03-28 04:52:59 UTC
Work has started on IZ 63030 and IZ 63630.  

This work may have practical application in the OpenOffice.org 1.1.x stream when
finished.  If not, then this issue can be closed when IZ 63030 is closed.
Comment 10 jjmckenzie 2006-03-29 16:15:51 UTC
Correction to my previous comments.

IZ 63030 is to fix packaging of empty directories (such as the template) when 
OpenOffice.org 2.0 is built.  This is caused by the change with MacOSX to the 
~/Library/Application Support/OpenOffice.org 2.0 directory from 
~/.openoffice.org2.

IZ 63630 is to discuss the useage of an installer vice drag-n-drop application 
folder.  

This issue is very old and was worked into an Applescript created by Terry 
Teague that starts the .soffice script in the same directory.  This is after 
calling and starting the X11 server/client program.

James
Comment 11 nospam4obr 2006-05-02 06:16:55 UTC
This will miss 2.0.3 unfortunatly.
Comment 12 pavel 2006-07-26 21:42:36 UTC
set target 2.x.
Comment 13 moxfox 2007-05-24 20:49:41 UTC
.
Comment 14 moxfox 2007-05-25 14:38:01 UTC
dmg + first start wizard seems to be the preferred grand solution
Comment 15 jjmckenzie 2007-05-26 03:03:18 UTC
I read over the comments on issue 63630 and agree that using an installer is not
exactly the best method for a simple program, but there are things that we do
with OpenOffice.org that may be easier with a packager.  However, drag and drop
is a much easier method to for the Mac and is very easy to implement and maintain.

+1 for the drag-n-drop method.
James
Comment 16 Martin Hollmichel 2008-06-06 15:18:17 UTC
close issue.