Issue 114106 - [SRB] ODF text reports: invalid root element in styles.xml
Summary: [SRB] ODF text reports: invalid root element in styles.xml
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: ReportBuilder (show other issues)
Version: DEV300m86
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-08-25 17:21 UTC by mst.ooo
Modified: 2017-05-20 10:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
fix problems (1.24 KB, patch)
2010-08-25 20:50 UTC, mst.ooo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description mst.ooo 2010-08-25 17:21:58 UTC
upload:///Table1_fixed.odt/styles.xml:Error:Invalid root element:
office:document-content
upload:///Table1_fixed.odt/styles.xml[2,2945]:Error:tag name "office:styles" is
not allowed. Possible tag names are: <body>

the second error seems to be a consequence of the first.
the root element for styles.xml must be office:document-styles.
Comment 1 mst.ooo 2010-08-25 20:50:19 UTC
Created attachment 71397 [details]
fix problems
Comment 2 mst.ooo 2010-08-25 20:52:35 UTC
the second error is not in fact caused by the first;
the ODF schema prescribes a specific order for the elements below the root:

    <define name="office-document-styles">
        <element name="office:document-styles">
            <ref name="office-document-common-attrs"/>
            <ref name="office-font-face-decls"/>
            <ref name="office-styles"/>
            <ref name="office-automatic-styles"/>
            <ref name="office-master-styles"/>
        </element>

the report builder writes automatic-styles before styles, which is wrong.
Comment 3 mst.ooo 2010-08-27 11:59:10 UTC
target 3.3
Comment 4 ocke.janssen 2010-08-30 08:22:34 UTC
Fixed in cws dba33h
Comment 5 ocke.janssen 2010-09-01 08:15:04 UTC
Please verify. Thanks.

- Execute the report as described in issue 112652
- Use the resulting odt and upload it on
http://tools.services.openoffice.org/odfvalidator/
- Run test

=> upload:///Table1_fixed.odt/styles.xml:Error:Invalid root element:
office:document-content
upload:///Table1_fixed.odt/styles.xml[2,2945]:Error:tag name "office:styles" is
not allowed. Possible tag names are: <body>


should be fixed
Comment 6 marc.neumann 2010-09-03 07:00:18 UTC
verified in CWS dba33h

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba33h