Issue 114210 - PDF export will generate only one page doc instead of two
Summary: PDF export will generate only one page doc instead of two
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO330m6
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-08-30 15:22 UTC by h.ilter
Modified: 2017-05-20 11:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bugdoc (11.06 KB, text/plain)
2010-08-30 19:05 UTC, h.ilter
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description h.ilter 2010-08-30 15:22:41 UTC
- Load bugdoc
- > It has two pages (both rigth side)
- Export to PDF
- Open the created pdf document
-> Doc has only one page
NOTE: you will get 3 pages, when you enable Export automatically inserted blank
pages at pdf export dialog
Comment 1 h.ilter 2010-08-30 15:56:28 UTC
And yes, regression to OOo 3.2.1
Comment 2 jbf.faure 2010-08-30 18:47:57 UTC
You forgot to add your bugdoc. Is it a MS-Word file or an ODF ?

Best regards. JBF
Comment 3 h.ilter 2010-08-30 19:05:26 UTC
Created attachment 71484 [details]
Bugdoc
Comment 4 thomas.lange 2010-08-31 09:52:27 UTC
TL->OD: I debugged the call stack from the beginning in 'getRendererCount' over
'render', 'PrintOrPDFExport', SwRootFrm::Paint down to the call of
  rInf.GetOut().DrawTextArray
in SwFntObj::DrawText. The 3rd (last) page is painted and when DrawTextArray is
called even the correct string is passed on.

Please have a look to see if the problem is on our side or on vcl's.
Comment 5 Oliver-Rainer Wittmann 2010-09-07 14:22:20 UTC
fixed in cws sw33bf09 - changed files:
/sw/source/ui/uno/unotxdoc.cxx,
/sw/source/core/doc/doc.cxx,
change set 1907aee4cd0d
Comment 6 Oliver-Rainer Wittmann 2010-09-13 11:23:35 UTC
od->hi: Checked in internal installation set of cws sw33bf09 - please verify
Comment 7 h.ilter 2010-09-15 19:02:25 UTC
Verified with cws sw33bf09 = OK