Issue 114522 - Moving of fly anchors not possible anymore
Summary: Moving of fly anchors not possible anymore
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOO330m6
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-09-15 13:08 UTC by Oliver Specht
Modified: 2017-05-20 11:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver Specht 2010-09-15 13:08:46 UTC
Insert dummy text and a text frame (or picture, or shape) and anchor it 'to
character' 
Select the frame and try to move the anchor with the mouse. 
->it moves a bit but then stops. After de- and reselecting the object the anchor
returns to it's previous position. 


In a DEV300m85 I also had some problems moving a to-paragraph anchor. I couldn't
reproduce this in OOO330.
Comment 1 Oliver Specht 2010-09-15 13:09:46 UTC
Target set to 3.4
Comment 2 Oliver-Rainer Wittmann 2010-09-16 06:57:11 UTC
Investigation reveals that the defect has been introduced in DEV300m76 - drawing
layer rework of hit test (usage of primitives)
Comment 3 Oliver-Rainer Wittmann 2010-09-16 08:07:54 UTC
adjusting target
Comment 4 Oliver-Rainer Wittmann 2010-09-16 09:23:11 UTC
fix in progress in cws sw33bf10
Comment 5 Oliver-Rainer Wittmann 2010-09-16 09:39:01 UTC
As requested by QA not to have to much cws this issue will be fixed in cws dba33j
Comment 6 eric.savary 2010-09-16 09:43:21 UTC
@OD: Thanx! :)
Comment 7 Oliver-Rainer Wittmann 2010-09-16 12:34:04 UTC
fixed in cws dba33j - changed file:
/sw/source/ui/docvw/edtwin.cxx, change set 90515075b1a0

The fix workarounds a problem with the handle hit test:
The handle hit test is performed on the used primitives for its representation.
The hit test is called for the top left corner (or the top right in
Right-To-Left or Vertical layout) of this representation. Due to floating point
operations in the hit test code a 0 becomes -1,77e-15 - close to zero, but not
zero. Thus, the hit test fails and the Writer interaction code for moving the
anchor handle fails.
Comment 8 Oliver-Rainer Wittmann 2010-09-23 08:55:18 UTC
od->es: Checked in internal installation set of cws dba33j - please verify.

Please also check the moving of the anchor in right-to-left and vertical layout
environments
Comment 9 eric.savary 2010-09-27 14:11:28 UTC
Verified in CWS dba333j