Issue 114719 - Error: caught an exception! (in SfxBaseController::ConnectSfxFrame_Impl)
Summary: Error: caught an exception! (in SfxBaseController::ConnectSfxFrame_Impl)
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: DEV300m88
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
: 115289 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-09-24 10:10 UTC by Frank Schönheit
Modified: 2017-05-20 10:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (66.71 KB, application/vnd.sun.xml.base)
2010-09-24 10:11 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2010-09-24 10:10:40 UTC
- (re)start OOo (this is important)
- open the attached database document
- open the contained report for editing
=> an assertion pops up, saying
  Error: caught an exception!
  in function:void __thiscall SfxBaseController::ConnectSfxFrame_Impl(const
    enum SfxBaseController::ConnectSfxFrame)
  type: com.sun.star.uno.RuntimeException
  message: invalid attempt to assign an empty interface of type
    com.sun.star.container.XIndexAccess!
  From File ooo/sfx2/source/view/sfxbasecontroller.cxx at Line 1474

Subsequent openings of the report do not yield this assertion, only after a
restart of OOo, you'll encounter it again.
Comment 1 Frank Schönheit 2010-09-24 10:11:07 UTC
Created attachment 71828 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2010-09-24 10:11:26 UTC
targeting to 3.4, since the fix is part of a CWS which aims for this release
Comment 3 Frank Schönheit 2010-09-24 10:11:44 UTC
oops, wrong script :)
Comment 4 Frank Schönheit 2010-09-24 10:11:57 UTC
assertion bug, hindering work with the non-product release => targeting to the
next feasible non-micro release
Comment 5 Frank Schönheit 2010-09-24 10:28:18 UTC
note: the real bug is triggered by the fact that the report designer loads an
empty, hidden document when it is first opened: The assertion is triggered
everytime a document is loaded hidden. To see this, the following macro can be used:

Sub load
  Dim args(0) as new com.sun.star.beans.PropertyValue
  args(0).Name = "Hidden"
  args(0).Value = true

  Dim doc as Object
  doc = StarDesktop.LoadComponentFromURL( "private:factory/swriter", _
    "_blank", 0, args() )
  doc.close( true )
End Sub
Comment 6 Frank Schönheit 2010-09-24 10:31:24 UTC
fixed in CWS dba34a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300/dba34a
Comment 7 Frank Schönheit 2010-09-29 08:41:33 UTC
fs->msc: please verify in CWS dba34a
Comment 8 Frank Schönheit 2010-10-28 11:02:43 UTC
*** Issue 115289 has been marked as a duplicate of this issue. ***
Comment 9 marc.neumann 2010-10-28 12:32:46 UTC
verified in cws dba34a