Issue 114725 - Error: <SwDoc::createListForListStyle(..)> - a list for the provided list style name already exists. Serious defect
Summary: Error: <SwDoc::createListForListStyle(..)> - a list for the provided list sty...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: DEV300m88
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Oliver-Rainer Wittmann
QA Contact: issues@sw
URL:
Keywords:
: 103860 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-09-24 12:21 UTC by Frank Schönheit
Modified: 2017-05-20 11:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2010-09-24 12:21:32 UTC
- (use en-US version of OOo)
- open a new text document
- enter "dt", press F3
=> an assertion pops up, saying
   Error: Assertion failed
   ==================
   FILE  :  ooo/sw/source/core/doc/docnum.cxx at line 2864
   ERROR :  "<SwDoc::createListForListStyle(..)> - a list for the provided
            list style name already exists. Serious defect -> please inform OD.
Comment 1 Frank Schönheit 2010-09-24 12:22:28 UTC
assertion bug, hindering work with the non-product release => targeting to the
next feasible non-micro release
Comment 2 Oliver-Rainer Wittmann 2010-09-24 13:22:56 UTC
*** Issue 103860 has been marked as a duplicate of this issue. ***
Comment 3 Martin Hollmichel 2011-03-16 11:44:24 UTC
set target 3.x since not relevant for 3.4 release.
Comment 4 Oliver-Rainer Wittmann 2011-05-06 07:58:59 UTC
fixed in cws sw34bf06 - changed file:
/sw/source/core/doc/docnew.cxx,
change set http://hg.services.openoffice.org/cws/sw34bf06/rev/051eaf9bfbe3

od->mba: please review the fix
Comment 5 mst.ooo 2011-05-10 08:29:11 UTC
verified in CWS sw34bf06