Issue 114728 - Support building AOO with OSX 10.7 SDK compatibility
Summary: Support building AOO with OSX 10.7 SDK compatibility
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.2.1
Hardware: Mac Mac OS X 10
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 122301
  Show dependency tree
 
Reported: 2010-09-24 13:24 UTC by pavel.lastovicka
Modified: 2014-04-01 12:46 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pavel.lastovicka 2010-09-24 13:24:44 UTC
Please support building OO.o on Snow Leopard against system headers and
libraries (or against SDK version 10.6).

I made some patches and successfully built OO.o with gcc 4.2, but program
crashed during smoketest.
Comment 1 eric.bachard 2010-09-24 16:35:14 UTC
+me on CC

I only have 10.4, but if ever I got a new machine some day, I'll have a look.
Comment 2 SVN Robot 2014-01-08 17:03:24 UTC
"hdu" committed SVN revision 1556579 into trunk:
#i114728# the quicktime framework is is no longer available in OSX SDKs>=10.7
Comment 3 SVN Robot 2014-01-09 09:55:40 UTC
"hdu" committed SVN revision 1556769 into trunk:
#i114728# fix linking of quicktime framework on SDK!=10.7
Comment 4 SVN Robot 2014-01-09 10:01:41 UTC
"hdu" committed SVN revision 1556774 into trunk:
#i114728# remove the unused gb_Library_add_ldflags helper
Comment 5 SVN Robot 2014-01-10 09:48:01 UTC
"hdu" committed SVN revision 1557067 into trunk:
#i114728# fix quicktime integration for OSX<10.7 build targets
Comment 6 SVN Robot 2014-01-21 10:37:16 UTC
"jsc" committed SVN revision 1559967 into branches/rejuvenate01:
#114728# use 10.7 SDK as default, but allow newer SDK in configure
Comment 7 jsc 2014-01-21 10:40:32 UTC
adapt configure to take 10.7 SDK as default but allow newer SDKs as well. Older SDKs are not longer supported.

Much more effort is necessary to support an older SDK like 10.6. If anybody is interested to work on this we can give advice. We will focus on newer systems only.
Comment 8 SVN Robot 2014-01-22 10:46:38 UTC
"hdu" committed SVN revision 1560309 into trunk:
#i114728# the quicktime framework was deprecated longer
Comment 9 SVN Robot 2014-01-23 17:10:14 UTC
"hdu" committed SVN revision 1560758 into trunk:
#114728# use 10.7 SDK as default, but allow newer SDK in configure
Comment 10 SVN Robot 2014-01-30 13:03:38 UTC
"hdu" committed SVN revision 1562805 into trunk:
#i114728# allow OSX platform SDKs that support OSX 10.7
Comment 11 SVN Robot 2014-01-30 13:33:19 UTC
"hdu" committed SVN revision 1562814 into trunk:
#i114728# improve configure diagnostics for the OSX SDK check
Comment 12 hdu@apache.org 2014-01-30 13:43:41 UTC
Fixed with the commits above.
Comment 13 SVN Robot 2014-02-06 14:14:28 UTC
"hdu" committed SVN revision 1565259 into trunk:
#i114728# set AOO's Mac baseline to OSX 10.7
Comment 14 SVN Robot 2014-02-14 13:44:34 UTC
"hdu" committed SVN revision 1568287 into trunk:
#i114728# force target compatibility when building with a newer OSX SDK
Comment 15 hdu@apache.org 2014-04-01 12:46:34 UTC
Closing the resolved issue.