Issue 114841 - Find & Replace current selection only (Calc Spreadsheet)
Summary: Find & Replace current selection only (Calc Spreadsheet)
Status: CLOSED DUPLICATE of issue 35093
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-29 22:14 UTC by streikpc
Modified: 2017-05-20 09:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description streikpc 2010-09-29 22:14:26 UTC
Find & Replace current selection only (Calc Spreadsheet)

When you make a selection, and then click "Find & replace" should always change 
blinds only in the selection.

Well, so the user has made the selection.

It has always been that way. Since the mid 80's, spreadsheets, Multiplan, Lotus 
123, Excel.

Changes to be made:
Change 1) If a selection is made. automatically activate "Current selecction 
only."

Change 2) If you will be first "Find & replace" and then makes a selection, 
too, automatically activate "Current selecction only."

Change 3 and also very important) Boxes "Current selection only" and "Regular 
expression" must be displayed to the right of the "Match case" and "Entire 
cells, and be no need to deploy" Fewer Options. "

Change 4) If a selection is made, this box should appear selected in gray, that 
can not be disabled.
Whether the selection is made before or after opening "Fin & replace".


For in modification of databases with spreadsheet, are two boxes that are used 
a lot, lot, and you save a lot of clicks, by not having to deploy and then 
check the box if you selected "Current selection only".

For example to replace the html codes for accents accents normal or listed in 
the column of a word translations from one language to another.

Just want to do in that column is selected, and if you have to translate 
thousands of words or expressions, automatic translator has done well, correct 
translation, many clicks you have to make at least double or triple clicks, 
which Multiplan, Lotus 123, Excel and , , etc, and that it has successfully 
simpre. Deploy "Fewer Options." to see these two boxes, is endless. In cmabio 
with the Excel spreadsheet, as when one slecciona something, he knows perfectly 
well that one is going to do ALWAYS on the selection, it is smart. If one 
selects a reason.

If a selection is always, always, always, the "Find & replace" tene to be on 
the selection.

and if you first open the box "find & replace" and then makes seleecion, too, 
must be provided only on the selection.

and what not to do is constantly having to deploy "Fewer Options" to see if it 
will replace only in the selection, because if you replace the entire document, 
and you spoil the whole database. And maybe you realize after 3 hours, then 
when you've also done a lot more work. You have to re-do everything, just 
because it was once this box checked.
So, if you make a CHOICE, ALWAYS ON THE CHOICE. ygual to put a background 
color, font etc.
When selecting, YOU DO IS ALWAYS ON THE CHOICE.
So if a selection is made, this box should appear selected in gray, that can 
not be disabled.
Whether the selection is made before or after opening "Fin & replace".

You have to be careful, because Calc stores, if selected or deselected "Current 
selecction only" at the following selection the user makes, and this too is a 
mistake. This must be removed.
Never have to remember, if you have activated in the previous "find & replace".

Anyway if you put the box on the right, next to "Match Case" and "Entire 
Cells", ie not have to deploy "Fewer Options", simpre is better because you 
make sure that only will take place in the selection much faster.

Let's do it. (I have contributed for example, no need to press the equal sign, 
when the first key is pressed, the minus sign, or plus sign. AND THEN WITH 
THESE CHANGES FROM THE SPREADSHEETS WIN A LOT). also come from this long. since 
the mid 80's, with the spreadsheet, Multiplan, Lotus 123 and Excel.

With the spreadsheet calc, Search and Replace in column selection is widely 
used to change only the columns selected databases within the spreadsheet.
Comment 1 Joe Smith 2010-09-30 12:15:33 UTC
I believe this is covered by Issue 35093
Comment 2 streik 2010-10-10 12:53:52 UTC
"Find & replace" if we made a selection, displayed in gray checked the 
box "Current selection only", and look to the side of the box "Match case" 
(very important and urgent change to be made, in the Spreadsheet, Calc)

When you make a selection and then click "Find and Replace" must always be 
changed only in the selection.

For this reason, the user has made the selection.

Always has been. Since the mid 80's, spreadsheets, Multiplan, Lotus
123, Excel.

Changes to be made, in summary:
Change 1) If a selection is made. automatically activate "Current selection 
only", and this box is in gray.

Change 2) If you first click on "Find and Replace" and then make a selection
also, same thing.

Change 3) (very important) Boxes "Current selecction only" and "Regular 
Expression" must be to the right of "Match case" and "Entire Cells", without 
having to press "Fewer Options."

To modify database from CSV spreadsheet
"Find & replace" is used a lot,
and if you make a selection,
bound only to be replaced in the selection,
why such selection is made.
(AND IDEALLY, THAT IS, WHAT YOU NEED TO CHANGE IS:)
to see, instantly, to open "Find & repolace" the box "Current seleectio only" 
is selected and gray, by default, when making a selection,
without pressing "option Fewer",

And so it saves many clicks, and get the job done in a third of the time.
Thing, that makes perfectly Excel, Lotus 123, Multiplan, etc

For databases with CSV files, often used to modify spreadsheet because the 
spreadsheet can be modified by selected columns, like a field.
Therefore, "Find & Replace" is used many, many times.

And make this change, save many clicks, because in this way, do not check 
constament, if activated or not, the box, "Current selection only".

Because we have to view it, at first sight. that is, right away, open the "Find 
& replace".

----------------------------------------
Not having to constantly check,
if this box checked for "Current selection only"
This saves you many clicks and time.
----------------------------------------

This change has to be done, because as it stands now, it takes three times as 
long, and if you make this change, it would take one third of time

As you do it correctly Excel, Lotus 123, Multiplan, etc.

It is something standard, that goes without saying, and is international. There 
are bound to do.
Comment 3 Marcus 2010-10-11 10:04:58 UTC
not a P1
Comment 4 streikpc 2010-10-11 11:40:20 UTC
Please, you can put part of the code here, to get started on the subject.
(Is that for a change, something completely different, we were 2 years, which 
was that if you put the sign - or + at the beginning of an addition or 
subtraction of cells was not necessary to put an equal sign at the beginning, 
and I would like this one change was faster is better).
Comment 5 streikpc 2010-10-12 00:28:22 UTC
Proposal to change even better:

Change 1) "Current selection only" with box,
must be transformed,
in only one phrase without box.

That what is a simple warning that "Find & replace"
will act only on the selection.
That is, a phrase. Without box.

Or whatever. If a selection is made, displays a phrase that says "Current 
selection only".

Change 2) If you first click on "Find & replace" and then makes a selection,
also, same thing.

Change 3) (very important)
* The phrase "Current selection only"
* And the box "Regular Expression"
must be to the right of "Match case" and "Entire Cells", without 
having to press "Fewer Options."

Change 4) If no selection, do not display the phrase, "Current selection only."
Comment 6 streikpc 2010-10-13 21:34:38 UTC
The change is best to do it this way:

Step 1) Change of position:
* The phrase "Current selection only"
* And the box "Regular Expression"
must be to the right of "Match case" and "Entire Cells", without 
having to press "Fewer Options."

 (The change of position, is the most important step of all steps to do.
Well, now, the program aims to save the box, but often the wrong stores.
Then you're forced to always check to see whether or not activated, and 
therefore, press "Fewer option" to view it.
And therefore, to always having to check, are double or triple clicks, and 
therefore double or triple time.

And is that, once that is not activated properly, and do not do well, and to 
corrupt the entire worksheet.

This box "Current selection only" and "Regular Expressions", it is very 
important that they are to the right of "Match case" and "Entire Cells", 
WITHOUT HAVING TO PRESS "Fewer Options").

* Step 2) If selection:

If selected area
ALWAYS enabled by default,
box "Current selection only".


* Step 3) If no selection:

If no selected area
be disabled, and gray.

* Step 4) Things to remove:

NEVER memorize selection of the box.
Whether a selection is made before or after opening the window "Find & Replace."

(Also, is it wrong now, because if after opening the window "Find & replace, to 
make a new one, with the window open, do not memorize the activation of the box 
properly. Well this is a bug has, but how you have to remove the memorization, 
so ... That's it. Never store the selection of this box)

* Step 5) Verification of the source code and verification program:

Check that work properly,
whether the selection is made
before or after
to open the "Find & replace".
Comment 7 Edwin Sharp 2013-07-31 07:00:06 UTC
Good suggestions present in bug 112334.

*** This issue has been marked as a duplicate of issue 112334 ***
Comment 8 Rainer Bielefeld 2013-09-03 06:15:12 UTC

*** This issue has been marked as a duplicate of issue 35093 ***