Issue 114884 - cleanup generated reference documentation
Summary: cleanup generated reference documentation
Status: CLOSED FIXED
Alias: None
Product: App Dev
Classification: Unclassified
Component: sdk (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial
Target Milestone: ---
Assignee: misheto
QA Contact: issues@api
URL:
Keywords:
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-10-01 12:50 UTC by jsc
Modified: 2017-05-20 09:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2010-10-01 12:50:13 UTC
I noticed that currently the not official and in most cased not or poor
documented vba api is part of the generated reference documentation in the SDK.
This is new and a mistake. I assume it is caused by building oovbaapi by default
now and deliver the idls in the global output tree.
Solution is top filter this api's for the SDK.

Furthermore the types defined in ooo/vba/msforms/MSFormReturnTypes.idl are
defined in the wrong package. Defined in "msforms" but should be in
"ooo.vba.msforms"
Comment 1 jsc 2010-10-05 09:43:57 UTC
please review
Comment 2 jsc 2010-10-05 16:54:32 UTC
ups forget to set the issue on fixed
Comment 3 misheto 2010-10-05 16:56:43 UTC
issue verified on cws sdk331.
Comment 4 misheto 2010-10-05 16:59:27 UTC
set target to OOo 3.3