Issue 114944 - AutoFilter don't work with RTL sheets
Summary: AutoFilter don't work with RTL sheets
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOO320m19
Hardware: Unknown All
: P2 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: regression
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-10-05 18:21 UTC by kaplanlior
Modified: 2017-05-20 10:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
ooo320m18 - arrow is in the left side of the cell and the list could be expanded (15.31 KB, image/png)
2010-10-06 12:23 UTC, netanel
no flags Details
ooo330m3 - arrow is in the right side of the cell, list couldn't be expanded (17.90 KB, image/png)
2010-10-06 12:25 UTC, netanel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kaplanlior 2010-10-05 18:21:21 UTC
It seems that AutoFilter doesn't work when the sheet is set RTL. Clicking on the
AutoFiler list doesn't expand the list of values to choose from. When changing
the sheet to LTR, the AutoFiler expands the list properly.

Notice that this isn't affected by the UI direction or the language (happens
with English and RTL UI). Only the sheet is RTL.

Step to reproduce:
1. Open a new sheet, type some text in a few cells.
2. Data -> Filer -> AutoFilter.
3. Check that the AutoFilter expands the value list.
4. Right click on the sheet's name and set it to RTL.
5. Repeating step #3 will fail.
6. Right click on the sheet's name and set it to back to RTL.
7. Repeating step #3 will succeed.

This issue was verified on both 3.2.1 (OOO320m19) and 3.3 beta (OOO330m7).
Setting to P2, as filters are quite important for working with calc.
Comment 1 netanel 2010-10-06 00:31:18 UTC
This is a regression between: oo320m18 (build 9502) [OK] >>> ooo330m3 (build
9519) [BUG].
In order to isolate the problem, are there any available builds between those two?
Comment 2 netanel 2010-10-06 00:38:44 UTC
Oh, my mistake. According to Kaplan version report, this is a regression between
oo320m18 and oo320m19. Sorry for the noise.
Comment 3 kaplanlior 2010-10-06 08:29:15 UTC
"According to Kaplan version report, this is a regression between oo320m18 and
oo320m19." 
I never wrote that...

I could also verify this issue with oo320m12 (3.2.0).
Comment 4 netanel 2010-10-06 09:42:19 UTC
According to Kaplan, his versions test is based on GO-Oo version, while my test
is based on the mainline versions.
In conclusion, the bug was created between oo320m18 (build 9502) and ooo330m3 (build
9519), and a clue to find the correct change is that this is a change which was
inserted earlier in Go-Oo (at least in oo320m12) and then in the mainline.
Comment 5 kaplanlior 2010-10-06 09:47:08 UTC
In any case, this issue is present in 3.3 beta (OOO330m7) from oo.org. 
Comment 6 netanel 2010-10-06 12:22:15 UTC
The issue may be related to the change in the positon of the arrow in the cell,
in ooo320m18 - RTL sheet, the arrow is in the left side of the cell (as it has
to be), and all is OK. In ooo330m3 - RTL sheet, the arrow is in the right side
of the cell (which is wrong) and the list couldn't be expanded. Screenshots
attached.
Maybe the wrong position of the arrow is the reason of the issue.
Comment 7 netanel 2010-10-06 12:23:42 UTC
Created attachment 71975 [details]
ooo320m18 - arrow is in the left side of the cell and the list could be expanded
Comment 8 netanel 2010-10-06 12:25:08 UTC
Created attachment 71976 [details]
ooo330m3 - arrow is in the right side of the cell, list couldn't be expanded
Comment 9 netanel 2010-10-06 12:28:37 UTC
BTW, I find a code-change in the code of the arrows in autofilter, it may be
realted to the issue.
http://hg.services.openoffice.org/cws/calcselectioncursor/rev/7ba13f4a900e
Comment 10 oc 2010-10-06 13:23:07 UTC
Hi Niklas, please have a look
Comment 11 ooo 2010-10-06 13:26:38 UTC
@netanel_h:
That specific change was not in any OOO320 build and also was not part of
previous Go-oo versions, it was introduced for DEV300/OOO330, see issue 109553,
and in this case is part of a rebase of CWS calcselectioncursor.
Comment 12 mdxonefour 2010-10-06 16:45:39 UTC
Issue has been accepted as stopper for 3.3, adjusting target accordingly
Comment 13 niklas.nebel 2010-10-06 17:04:02 UTC
Fixed in CWS "ooo33gsl10".
Comment 14 niklas.nebel 2010-10-06 17:54:18 UTC
reassigning to QA for verification
Comment 15 oc 2010-10-07 13:05:59 UTC
verified in build cws_ooo33gsl10