Issue 114963 - multiple instances of soffice.exe
Summary: multiple instances of soffice.exe
Status: VERIFIED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.2.1
Hardware: PC Windows 7
: P3 Trivial with 37 votes (vote)
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 100126 115076 116475 116545 116557 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-10-06 16:35 UTC by lewg
Modified: 2016-11-09 10:06 UTC (History)
20 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
multiple instances of oo (41.94 KB, image/png)
2010-10-06 16:38 UTC, lewg
no flags Details
Enable IPC before OpenClients to allow client connections when printing (1.34 KB, patch)
2014-05-14 12:26 UTC, aptitude
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description lewg 2010-10-06 16:35:52 UTC
This happens regularly.  I'm using version 3.2.1, OOO320m18, build 9502. 
Windows 7 home premium. 

After I've opened a calc and/or writer file from the taskbar icon more than
once, nothing happens when I ask for another one.  I don't know how many times
precede the non-responsive request.  

At that point Task Manager shows multiple instances of soffice.exe, soffice.bin,
and writer and calc.  From Task Manager, if I close soffice.exe with End Process
tree, that closes all preceding instances and opens the file that I want.
Comment 1 lewg 2010-10-06 16:38:15 UTC
Created attachment 71979 [details]
multiple instances of oo
Comment 2 john_ha 2010-10-14 12:53:02 UTC
This regularily happens to me.  I have posted it in the forum as "OOo hangs with
multiple soffice.exe in Task Manager" (see
http://user.services.openoffice.org/en/forum/viewtopic.php?f=15&t=34922#p160112 )
I have a gut feeling, for which I have no conclusive evidence, that it happens
when I have shut down the last instance of OO, and I then immediately start a
new instance of OO before the previous instance has completed its shutdown.

The sequence is:

If I am using OO Writer, and I close all instances of OO, and I then quickly
restart OO again, OO often hangs. (You know the sequence - you are editing
something - you close it - and at that precise moment you remember you forgot
something - so you immediately restart it.)

When OO hangs, I start Task Manager and I always see multiple (sometimes 5 or 6)
copies of soffice.exe and / or (s?)office.bin. The only way to get out of the
hang is to use Task Manager to End Process with all these processes. I always
use right click on one process > choose End Process Tree, and sometimes several
of them disappear when I end just one as though they were part of a called tree.
Once they are all gone OO is fine again.

Other factors which may be relevant are that I often seem to be opening an odt
or doc or docx file still attached to an email (I use Thunderbird for emails)
when it happens. I open such attachments by double left clicking on the
attachment icon.

When I have closed all instances of OO, I invariable restart OO by clicking on
the QuickLaunch icon in the Windows System Tray (the Quicklaunch icon runs
soffice.exe). It only needs 1 click, but I usually forget and double click the
Quicklaunch icon by mistake. The multiple instances in Task Manager may be
because I double click on the Quicklaunch icon 2 or 3 times when OO doesn't
start up.

When I do a standalone test (no OO instances running > double click quickly on
the Quicklaunch icon), just one instance of OO starts OK.

I think it started within the past 6 or 8 months.  I always keep OO up to date.

OO 3.2.1 Build 9502, Windows 7 Home 64 bit, Intel dual 2.3GHz core, 4GB, Thunderbird
Comment 3 alanmintaka 2010-10-18 23:51:35 UTC
*** Issue 114963 has been confirmed by votes. ***
Comment 4 alanmintaka 2010-10-19 00:06:59 UTC
This is now happening on my systems too.  When multiple copies of soffice.bin
reside in memory, OO programs will not open.  

Note: This happened after a delay of a few hours between OO program runs.  Thus
waiting a minute or two between closing one OO program and launching another
would not have helped.

Like some of the other posters, I've been working around the problem by killing
the soffice.exe and soffice.bin processes in the task manager.

Two different systems have been affected.

Info system 1:

PC: Dell Dimension 8300 3.2GHz 4GB RAM 2HDD 350GB free total
OO version: 3.2.1 000320m18 build 9502
OS: Windows 7 Home Premium v6.1 build 7600
AV: Ad-Aware Internet Security Free 8.3.4
Firewall: ZoneAlarm Free 9.2.057.000
MS Office: Not installed

Info system 2:

PC: Dell Dimension 8400 3.2GHz 4GB RAM 2HDD 400GB free total
AV: Avast 5.0.677
Everything else is the same as system 1.
Comment 5 stefan.baltzer 2010-11-18 12:16:18 UTC
*** Issue 115076 has been marked as a duplicate of this issue. ***
Comment 6 strob 2010-11-19 11:15:12 UTC
Multiple soffice.exe-processes aren't the problem. More problematic is the
existence of multiple soffice.bin-processes...

One way to get more than one soffice.bin-process is:
1) save a odt-document on your desktop
2) right-click the icon
3) press "Print" in the context-menue
4) replay step 2 and 3 several times

After you've done this, you aren't able to open a document by double-clicking.
I've tested this behavior with OOO320m19 and Windows 2000. 

Hopefully i don't mix up different problems...
Comment 7 mikeeoo 2010-11-20 01:56:52 UTC
I get this by opening multiple calc workbooks (which sometimes link to each
other and some external files), then exiting them quickly such as by menu
File_Exit. Saving then closing (as separate actions) makes it happen even more
reliably. If I close them one at a time and wait a minute or so in between it
usually does not happen. Symptom of the problem is that attempting to open a new
file after all the others are closed doesn't work -- brief hourglass then
nothing. Opening Task Manager and killing all the soffice & scalc tasks fixes
it. This was very rare under XP SP3 Home on the same hardware with OO 3.2.0 but
is common with Windows 7 Pro (fully patched).

OO 3.2.1 Build 9502, Windows 7 Pro 32 bit, Pentium D 945, 2GB, Thunderbird,
Quickstarter not active
Comment 8 malibu2 2010-12-02 17:34:11 UTC
Oo 3.2.1 build 9502.
Windows 7 Home Premium

I also see multiple instances of OpenOffice in the Task Manager after closing
OpenOffice. I cannot open Oo until I kill all the soffice.exe processes. 

Sometimes killing just 1 instance will close all the other instances in Task
Manager. 

Very bothersome. Please fix. 
Comment 9 cjf20000 2010-12-05 15:55:41 UTC
I have this same problem and it is really starting to annoy me now. I have also 
raised an issue....nobody has come back to me or resolved it as yet...... I am 
running OOo 3.2.1, build 9502 on windows Vista.
Comment 10 guillaume47 2010-12-07 14:44:38 UTC
I have same issue using Windows XP Pro SP 3 & OOo 3.2.1
Comment 11 lewg 2011-01-11 18:54:26 UTC
I keep running into this a couple times a week.  Software shouldn't do this.

Today I was in and out of Writer a few times with no apparent problems -- just
look at something, maybe add a few characters to one file, then save (or not)
and exit.  At some point I couldn't get in -- I click on the icon and nothing
happens.  As usual, I looked at Task Manager.  I saw THREE instances EACH of
soffice.bin, soffice.exe, and swriter.exe.  

Today I had to "End process tree" on each of the soffice.exe entries.  Other
times, doing just one will close all of them.
Comment 12 Regina Henschel 2011-01-16 00:10:15 UTC
*** Issue 116475 has been marked as a duplicate of this issue. ***
Comment 13 Oliver Brinzing 2011-01-16 14:58:29 UTC
from Issue 116475 

this usually happens if oo quickstart is *disabled*,
see menu Tools - OpenOffice.org - Memory:
[x] Load OpenOffice.org during system startup

if one closes oo and opens another document
immediatelly the result can be two "soffice.bin".

another known scenario (vista):
if one tries to open an oo document inside firefox
browser, oo fails to start if the user has no admin 
privileges - firefox statusbar will only show some
"..." in the left corner ... and a "soffice.bin" will
stay in the task list.

see Tools - Options - Internet - Mozilla Plugin
it is also not possible to activate/deactive the option
in that case, it seems i have no write access for:
[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@sun.com/npsopluginmi;version=1.0]
"Path"="C:\\Program Files\\OpenOffice.org 3\\program"
Comment 14 papayes 2011-01-21 08:12:37 UTC
Confirmed on Vista with 3.3.0 RC3 as soon as the first record after unexpected
OOo Writer :
 17 processes open !
Comment 15 Olaf Felka 2011-01-21 13:02:24 UTC
*** Issue 116545 has been marked as a duplicate of this issue. ***
Comment 16 vitriol 2011-01-21 15:15:50 UTC
Add me to CC.
Comment 17 Olaf Felka 2011-01-22 10:04:29 UTC
*** Issue 116557 has been marked as a duplicate of this issue. ***
Comment 18 commmo 2011-01-25 12:42:01 UTC
Same goes on Windows 2003 server; here we use abcPDF under IIS and that triggers 
multiple soffice.bin/exe instances.
Comment 19 anutthara 2011-02-02 04:37:45 UTC
Windows XP (Up to date as of 2/1/11)

If I open an office document, close it, then open another, ooo freezes and
nothing will open. It does not matter how much time passes between closing the
last ooo instance and starting a new one. To fix the problem I have to open task
manager and close the (multiple) soffice.bin soffice.exe etc processes.
Comment 20 Marco Marani 2012-05-04 08:28:44 UTC
We use OO embedded into a Java Applet and also experience this problem on multiple Windows environments. This applet runs an enterprise application, it is very difficult for us to manage this situation on customers.
Comment 21 stefan.achten 2012-11-19 13:03:27 UTC
Problem is also occuring on our setup:
-Windows Server 2008 R2 SP1 Standard
-Citrix XenApp 6.0 RUP 1. 
-OpenOffice 3.3 (3.4 already tested and is also having this issue)
Comment 22 edamphil 2013-08-20 23:44:40 UTC
This still occurs on open office 3.4.1 and windows xp
Comment 23 aptitude 2014-05-07 11:59:08 UTC
This bug still occurs in OpenOffice 4.1.0

In can easily be replicated by using ::ShellExecuteEx() with "print" as the verb in SHELLEXECUTEINFO.

If you call it repeatedly without a pause in-between, then only the first print occurs and multiple soffice.bin and soffice.exe tasks are active in the windows task manager.
Comment 24 aptitude 2014-05-14 12:26:58 UTC
Created attachment 83383 [details]
Enable IPC before OpenClients to allow client connections when printing

Fixed as follows:

Enable IPC thread before OpenClients

This is because it is possible for another client to connect during the OpenClients() call.

This can happen on Windows when document is printed (not opened) and another client wants to print (when printing multiple documents).

If the IPC thread is enabled after OpenClients, then the client will not be processed because the application will exit after printing. i.e OfficeIPCThread::AreRequestsPending() will always return false

ALSO:

Multiple clients may request simultaneous connections.
When this server closes down it attempts to recreate the pipe (in DisableOfficeIPCThread()).
It's possible that the client has a pending connection request.
When the IPC thread is not running, this connection locks (because maPipe.accept()) is never called
Comment 25 Kay 2015-10-03 21:27:11 UTC
Patch needs review by the API folks. Not tested yet.
Comment 26 Andrea Pescetti 2015-10-03 21:51:02 UTC
Adding to Kay's comment: there are a number of people who commented on this issue over the months, even years. It still remains a uncommonly reported issue by the OpenOffice standards, but a patch is now available (thanks!) and I wonder how many have tested it.

If we include it into trunk and produce a development Windows build that includes it, will testing become easier for those of you who can replicate the problem? Is anyone already running a modified version of OpenOffice which includes this patch?
Comment 27 aptitude 2016-01-19 15:05:51 UTC
I do not believe that anyone has tested it (except me). 

It probably will be a good idea to include it into the development windows build.

This bug will only affect a few users that require printing multiple files
Comment 28 oooforum (fr) 2016-01-27 13:57:28 UTC
Set issue type as PATCH
Comment 29 Ramiro 2016-09-05 17:55:58 UTC
I'd like to state that Libre Office 5.1.4.2 (build ID f99d75f39f1c57ebdd7ffc5f42867c12031db97a) still has this problem on Windows 7.
Comment 30 Andrea Pescetti 2016-09-05 18:06:59 UTC
The OpenOffice buildbots have been back to regular operations for a few weeks. We'll commit the patch to trunk later this week, but then please provide feedback with a build from https://ci.apache.org/projects/openoffice/install/win/ after the update. More information coming in the next days.
Comment 31 Keith N. McKenna 2016-09-05 18:48:04 UTC
(In reply to Ramiro from comment #29)
> I'd like to state that Libre Office 5.1.4.2 (build ID
> f99d75f39f1c57ebdd7ffc5f42867c12031db97a) still has this problem on Windows
> 7.

Ramiro;
This is the bug reporting system for Apache OpenOffice and has no formal connection with LibreOffice system. To report this bug in LibreOffice you need to report to them. See the documentation at the following link for help on submitting bugs to LibreOffice: https://wiki.documentfoundation.org/QA/BugReport
Comment 32 Ramiro 2016-09-06 12:55:31 UTC
> Ramiro;
> This is the bug reporting system for Apache OpenOffice and has no formal
> connection with LibreOffice system.

Indeed. Sorry for the mess.
Comment 33 SVN Robot 2016-09-06 19:13:45 UTC
"pescetti" committed SVN revision 1759486 into trunk:
#i114963# Enable IPC before OpenClients to allow client connections when prin...
Comment 34 Andrea Pescetti 2016-09-06 19:17:31 UTC
The patch for Apache OpenOffice contributed by user "aptitude" has now been committed to the Apache OpenOffice trunk. Thanks!

Please do test it and report here.

To do that, you will need a development snapshot of Apache OpenOffice 4.2.0 (an unofficial pre-release version) that can be found here:
https://ci.apache.org/projects/openoffice/install/win/

You likely want the last file there, about 135M. Revision number must be higher than 1759486, so you'll need to try about 24 hours from now.
Comment 35 aptitude 2016-09-08 08:20:21 UTC
I can confirm that Apache_OpenOffice_4.2.0_Win_x86_install_en-US_1759486 fixes the problem.

Many thanks.
Comment 36 Marcus 2016-09-08 18:02:37 UTC
Thanks for your verfication. I'll forword this to our release manager. Maybe an issue for the planned 4.1.3 release.
Comment 37 Andrea Pescetti 2016-09-08 21:50:11 UTC
For considering this for 4.1.3 (in addition to the Release Manager, Patricia, opinion) we would need a QA procedure. A step-by-step process like "1. Be on Windows 7; 2. Right-click in rapid succession on 4 ODT documents on your desktop, printing all of them 3. Open Task Manager..." and so on. If user "aptitude" or others can contribute this, it would be perfect.

Also note that we might be very conservative for 4.1.3; but if we remove the main concern I (as Release Manager for 4.1.2) had in accepting this for 4.1.2, i.e., lack of testing, then chances might be a bit higher.
Comment 38 oooforum (fr) 2016-11-09 10:06:39 UTC
*** Issue 100126 has been marked as a duplicate of this issue. ***