Issue 115443 - OO Math crashes when opening the following formula
Summary: OO Math crashes when opening the following formula
Status: CLOSED FIXED
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOO320m12
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: 3.4.1
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-06 16:55 UTC by vvzh
Modified: 2011-02-10 15:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample bug doc (5.17 KB, application/octet-stream)
2010-11-08 08:05 UTC, thomas.lange
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vvzh 2010-11-06 16:55:49 UTC
alignl size 10 { w_V = left lbrace matrix{ 1, phantom {sum to {}{}} # V in Y ##
0, phantom {sum from {} to {} {}}  # V in ST ## sum from {X: exists E = lbrace
X, V rbrace } w_X, # V in A union RT } right none }

Steps to reproduce:
1) Enter the formula above into the blank Math document, or insert it into
formula object embedded into Writer document.
2) Save the document.
3) Open Math document, or open Writer document containing the formula and try to
edit the formula.
4) OOo crashes, notifying you about documents it is going to recover.

The problematic part of the formula is "sum from {} to {} {}" (particularly
"from {}" part). When replaced with "sum from {a} to {} {}" or "sum to {} {}" it
works as expected. The issue is quite trivial to workaround, but the the crash
is uncomfortable, because it does not allow you to fix the problem using OOo and
requires you to manually edit underlying MathML code.
Comment 1 vvzh 2010-11-06 16:57:50 UTC
The problem is confirmed to happen with OOo 3.2.1 too.
Comment 2 thomas.lange 2010-11-08 08:04:05 UTC
Yes the empty braces {} are the reason in this context. Seems to be more like an
export problem since the ODF validator correctly complains about the document.
(See also attached document). 
Other applications however (e.g. Firefox) seem to be fine with this broken ODF.
Comment 3 thomas.lange 2010-11-08 08:05:07 UTC
Created attachment 72892 [details]
Sample bug doc
Comment 4 thomas.lange 2010-11-08 08:06:37 UTC
Text of the sample bug doc:

matrix{ 
1 phantom {sum to {}{}} ##
2 phantom {sum from {} to {} {}}  ## 
sum from X w }
Comment 5 thomas.lange 2010-11-08 08:07:56 UTC
.
Comment 6 thomas.lange 2010-12-01 13:05:00 UTC
Fixed in CWS tl84.
Since it was the export that got fixed the attached bugdoc still can't be read
even in the fixed office, but with the fix such broken files will not be written
anymore now.

Files changed:
M source\mathmlexport.cxx
Comment 7 thomas.lange 2010-12-10 09:45:20 UTC
TL->MRU: Please verify. Thanks!
Comment 8 michael.ruess 2010-12-15 10:11:37 UTC
Verified in CWS tl84.
Comment 9 michael.ruess 2011-02-10 15:24:14 UTC
Checked in DEV300m99.