Issue 116005 - Copy / Paste as (GDI or CALC8) causes crippled view in WRITER
Summary: Copy / Paste as (GDI or CALC8) causes crippled view in WRITER
Status: CLOSED DUPLICATE of issue 115825
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: DEV300m92
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-09 05:04 UTC by Rainer Bielefeld
Modified: 2011-01-24 09:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test kit for original report (165.73 KB, application/x-compressed)
2010-12-09 05:19 UTC, Rainer Bielefeld
no flags Details
The second test files group from LibreOffice bug tracking for my posted test results (35.36 KB, text/plain)
2010-12-10 12:17 UTC, strata
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2010-12-09 05:04:46 UTC
My "Ooo-Dev 3.4.0 multilingual version German UI WIN XP: [OOo300m92 (Build
9541)]" leaves a completely crippled result when I copy / paste special - GDI
Metafile from a speradsheet. Please compare result in "copypasteresult.odt" (and
screenshot in same document) with original table in "sample.ods" sheet
"Reparatur_Erforderlich"!

Steps to reproduce:
0. Unzip testkit
1. Open new WRITER document and save in same folder as "sample.ods"
2. open "sample.ods" 
3. go to sheet "Reparatur_Erforderlich"
4. 'Click A1'
5. Use vertical scroll slider to get 'J17' visible
6. <shift> + <left click> into 'J17'
7. <cntrl>+<c> for "Copy"
8. switch to new WRITER document
9. Icon 'Paste -> as GDI Metafile'
   Expected: Pasted Table looks very similar to original in one spreadsheet
   Actual: heavy damages as shown in Screenshot in "copypasteresult.odt" 

I have been doing so for years with OOo, never saw such problems. If you do the
test with 3.1.1 the result will be as expected.
Comment 1 Rainer Bielefeld 2010-12-09 05:19:07 UTC
Created attachment 75292 [details]
test kit for original report
Comment 2 Rainer Bielefeld 2010-12-09 05:27:59 UTC
Same with "Ooo-Dev 3.4.0 multilingual version English UI WIN XP: [OOo300m95
(Build 9553)]"!
Comment 3 Rainer Bielefeld 2010-12-09 07:09:21 UTC
It's even worse, pls. see <https://bugs.freedesktop.org/show_bug.cgi?id=32236>
from LibreOffice, what suffers from the same problem.
Comment 4 Rainer Bielefeld 2010-12-10 05:58:23 UTC
DRAW and WRITER objects also affected, for details pls. see LibO link. I saw all
results also in DEV300m95
Comment 5 strata 2010-12-10 12:02:35 UTC
I also test the bug on my updated OpenSuSE 11.2 x86-64, Gnome 2.30.2 (also
installed KDE 4.5.4) with:

- LibreOffice 3.3.0, OOO330m17 (Build:3), libreoffice-build 3.3.0.1, linux
x86-64 (OpenSuSE Build Service release from here:
http://download.opensuse.org/repositories/LibreOffice:/Unstable/
rc1 said)

- OpenOffice.org 3.3.0, OOO330m17 (Build:9551), linux x86-64 (vanilla one, rc7
said)


*testkit* results

- Both OOo and LO works fine (!)
- and also your "copypasteresult.odt" opens fine (!!!), Windows port rendering
trouble?


*AdditionalTestKit* results

- pasting all "WriterSample.odt" content into Impress / Draw (both tested):

-- both OOo and LO works the same;
-- text is *badly* rendered: only the first text line is rendered in the Writer
object inside Impress / Draw and that line is repeated n times (as you already
pointed out);
-- this behavior is the same also running the presentation in Impress.


- pasting Draw object into Writer / Impress

-- both OOo and LO works the same;
-- text is *badly* rendered: the first line of each paragraph is repeated n
times, where n seems to be exactly the number of lines in which each paragraph
is rendered in the original Writer / Impress object (!!!); may be some
programming counter/pointer has been forgotten and not updated so that only the
first line paragraph is copied n times?
-- this behavior is the same also running the presentation in Impress.


I have posted these test results both on OOo and LO bug trackers.

HTH,

Carlo
Comment 6 strata 2010-12-10 12:15:34 UTC
Let me add my personal opinion.

With the big regression amount experience for 3.3 and the fact that the 3.3
hasn't (correctly!!!) been released, I think it is NOT the time to start develop
OOo 3.4!!!

I think we MUST fix the bigger part of OOo 3.3.0 and THEN (and only, solely
then!) branch the trunk to develop 3.4 or above versions.

I want to see how many times now on fixes from OOo 3.3.x are communicated and
ported to trunk (3.4 or above).

I finally think that this is not happened or taken place many times in the
analog situation from OOo 3.2.x and the trunk for 3.3, isn't it?

This IS the big (human, developer and manager) trouble (people trouble) and MUST
be fixed asap and definitively, for now on!

Carlo
Comment 7 strata 2010-12-10 12:17:20 UTC
Created attachment 75309 [details]
The second test files group from LibreOffice bug tracking for my posted test results
Comment 8 Rainer Bielefeld 2010-12-11 12:12:46 UTC
Seems to be a DUP. although Issue 115825 is only for Spreadsheet problem.

*** This issue has been marked as a duplicate of 115825 ***
Comment 9 thorsten.martens 2011-01-24 09:23:00 UTC
closed