Issue 116132 - Characters Not Rendered in Math
Summary: Characters Not Rendered in Math
Alias: None
Product: Math
Classification: Application
Component: ui (show other issues)
Version: OOO320m19
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2010-12-15 12:19 UTC by oeconomist
Modified: 2013-04-02 19:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description oeconomist 2010-12-15 12:19:45 UTC
Using OpenOffice 3.2.1 on Red Hat Enterprise Linux 6.0, when characters U+22b3,
U+22b5, U+227b (‘≻’), U+227f (‘≿’), and U+2280 (‘⊀’) are entered in formulae
they appear in the editing area, but are not rendered in the output. (These
characters are rendered by Writer when entered as ordinary text therein.)
Comment 1 michael.ruess 2010-12-16 10:21:29 UTC
Looks like the same problem as issue 113586. Please check if the described
workaround works on your system, thanks!
Comment 2 oeconomist 2010-12-16 12:32:06 UTC
No, the work-around at issue 113586 does not resolve this problem.

OpenOffice was installed using the root account, and the font is presently and
only installed system-wide and as per the OpenOffice packages.

(All Greek letters (including digamma, qoppa, and sampi) are rendered without
apparent difficulty, whereas issue 115620 (indicated to be a duplicate of
113586) involved their not being rendered.)
Comment 3 michael.ruess 2010-12-16 16:12:05 UTC
Cannot reproduce with OOo 3.2.1 on Solaris or Suse 11. Do you work with OOo
downloaded from or the one provided by Redhat? Please try the one
from our download page.
Comment 4 oeconomist 2010-12-16 16:16:46 UTC
I got the sale results using the version from (first) and that
from Red Hat (second).

When I posted to a Red Hat El 6 mailing list, someone experimented and got the
same problematic result.
Comment 5 michael.ruess 2010-12-23 09:32:58 UTC
OOo 3.3 has a new, enhanced OpenSymbol font. Could you please try if with latest
OOo 3.3 RC8.
I was not able to see the mentioned problem on RedHat Enterprise linux using OOo
Comment 6 oeconomist 2010-12-23 13:19:46 UTC
I fully installed OpenOffice 3.3.0 RC, and restarted the system; the problem
persists in documents that were configured to use Times New Roman for variables
in documents that were configured to use Liberation Serif, and in newly created
documents configured to use the latter.

(ΤΕΧ Gyre has no problem, but I have literally hundreds of existing formulae in
documents that are in-play, and there is no mechanism for globally changing the
font settings of these.)

As noted, at least one other person on the standard RHEL 6 mailing list reports
the same problem. (I have not received word from anyone on that list of an
inability to reproduce it, FWLIW.)
Comment 7 michael.ruess 2011-01-11 11:57:34 UTC
Could you please try to copy the OpenSymbol font from
OOo3.3/ to your systems font
directory e.g. /usr/share/fonts/truetype ? This also helped on my SUSE 11.x system.
Comment 8 oeconomist 2011-01-11 23:22:45 UTC
Unfortunately, the problem persists.

I stripped OpenOffice from my system, reinstalled 3.3.0 RC, copied the
OpenSymbol font also to /usr/share/fonts/truetype/, ran fc-cache, started
OpenOffice and set a JVM, restarted the computer, and checked.  The characters
remain invisible.

(Meanwhile, as of 7 Jan, Red Hat refuses to examine the problem “Because the
affected component is not scheduled to be updated in the current release”; which
is to say that they won't look for a problem because they wouldn't bother to fix
it anyway!)
Comment 9 michael.ruess 2011-01-12 13:37:27 UTC
I'm quite out of ideas...
MRU->PL/HDU: do you have any hint/idea why this may not work on the mentioned
Comment 10 thomas.lange 2011-01-12 14:27:16 UTC
TL: adding me to cc list. BTW the problem does not seem to exist with Windows
(OOo 3.2.1).
Comment 11 thomas.lange 2011-01-12 14:37:26 UTC
tl->oeconomist: As a work-around please try to define those characters as
symbols in the symbol catalog and then make use of it. The difference would be
that in the symbol define dialog you can explicitly choose which font is to be
used whereas you can not influence what font gets used if you simply type that
character in the edit window.
Also if you are already using 3.3 or a current developer snapshot you can now
easily see the Unicode position of the selected characters.

You can also try to set ALL the top 4 fonts listed in the Format/Fonts dialog to
a font that actually contains those characters, because at least on my Windows
box the Times New Roman does NOT contain those characters which might be part of
the problem.
Comment 12 oeconomist 2011-01-12 23:22:00 UTC
The problem with either of those work-arounds is that I have active documents
with hundreds of pre-existing formulæ, and cannot simply effect global changes.
Comment 13 thomas.lange 2011-01-13 09:21:50 UTC
TL: HDU said it seems the issue can not be solved unless the problem can be
debugged. It probably is a problem with font fall back which seems to find the
characters in case of the edit window but not in case of the graphic window.

Thus the problem needs to be reproduced in-house in order to look further into this.
Comment 14 oeconomist 2011-01-13 10:30:38 UTC
I believe that, specifically, there is a problem with how OpenOffice interacts
with that version of fontconfig that is distributed with RHEL 6.0, or at least
with that for the i686.
Comment 15 michael.ruess 2011-01-17 15:52:49 UTC
I think that OOo Math uses an incorrect fallback for those characters. The
characters you mentioned above are not available in OpenSymbol. Please map these
characters with the correct font in Tools.Catalog.Edit. Does this help?
Comment 16 oeconomist 2011-01-18 00:34:49 UTC
Creating new entries in the Catalogue would side-step the problem for future
formula, but so would just using a font (such as some created for ΤΕΧ) which
simply has those symbols.

My problem is that I already have multiple documents in-progress, some having
hundreds of formulæ, with the font specified either to be Liberation Serif or to
be Times New Roman.  When I was using OpenOffice under RHEL 5.5, the symbols in
question were properly rendered.  When I converted the system to RHEL 6.0, the
symbols vanished from the rendering.
Comment 17 michael.ruess 2011-03-10 10:21:46 UTC
OK, you upgraded your system from RHEL 5.5 to 6... Maybe the fonts are now differently on your system?
Is there any font on your system which has the mentioned characters inside? I mean, if not, there is nothing which can be fixed on OOo's site...
Comment 18 oeconomist 2011-03-23 06:18:32 UTC
There are a number of fonts in my system that have the desired characters.  See comment #6 for specific reference to one of them, and #16 for vaguer reference.  Your proposals have run in circles, apparently without memory of what has been tried and failed.  It has been like watching a house cat try to solve a problem.

So, instead, I've used Writer2LaTeX to convert the documents to LaTex, and then imported them into LyX. ( )  Yeah, I'd like to have far more WYSIWYG than LyX provides, but an application that works is better than one that fails catastrophically, even if the former doesn't have as nice a UI.

I'm done using OpenOffice for professional work, and I've warned friends and colleagues about it.
Comment 19 michael.ruess 2011-03-23 06:39:08 UTC
I hope that you are aware of the fact, that you get a professional product for free - and I hope you are aware of the word "community".
Can you imagine, that it is difficult to properly serve almost EVERY Unix distribution on the world? Just these facts should give you the hint, that it is not possible for us to offer support free off charge.
Maybe you get help on on channels like Just before shouting out loud and blame members you should think about these facts.

I tried to replicate your problem on Oracle Enterprise Linux which is based on RHEL 6. But it worked correctly with OOo 3.3 and 3.4-dev. So it ist almost like viewing a crystal ball for things which are differently on our systems... and here the word "community" should take its place...
Comment 20 oeconomist 2011-03-24 07:02:01 UTC
No, part of the inevitable conclusion here is that OpenOffice Math is *not* a professional product.  It's interesting, and may eventually evolve into a professional product; but right now it's something less.

I've supplied free programs for, literally, decades, and never regarded "free" as an excuse for bugs.  You're on *much* better ground when you note the difficulty of attempting to support ever version of Linux.  But OpenOffice needs to change how it represents itself if it's not up to proper font-fallback on Linux.

You're confusing the unpleasantness of the facts with supposed shouting.  I'm entering the same sized characters here as are you, and making no peculiar reliance upon upper-case letter.

And I have tried other channels; others found the same problem; no one had a better solution than to report it as a bug.  Okay.  That -- reporting it as a bug -- too doesn't work.  The bug will abide.

The meta-solution is to change word-processors; I'm content with that.  And if someone else comes here looking for the solution, perhaps the meta-solution will be enough for them.
Comment 21 Rob Weir 2013-02-02 02:59:20 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
Comment 22 oeconomist 2013-02-02 04:33:59 UTC
Haha!  You've had a thorough description of the problem.  Pretty much the only information left to give would be the solution, which I don't have.

Well, that is to say that I don't know how to fix the broken-ness of OpenOffice Math.  But, as I've explained, one solution to the underlying problem is simply to give-up on this half-baked software and go to LyX, which I did years ago.

Have the day that you deserve, Mr Weir.
Comment 23 Rob Weir 2013-04-02 19:12:59 UTC
No offense intended.  This was a bulk notice added to 400 or so issues that were stuck in the "needmoreinfo" state.  It sounds like we have enough info and can remove that keyword.