Issue 116178 - SUMIF Bug when Comparing Against "" (For Blank Cells)
Summary: SUMIF Bug when Comparing Against "" (For Blank Cells)
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: programming (show other issues)
Version: OOo 3.2.1
Hardware: PC (x86_64) All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-19 22:52 UTC by dgm0814
Modified: 2013-08-22 18:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.0
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dgm0814 2010-12-19 22:52:14 UTC
Example:

=sumif(C1:C3,"",B1:B3)

This should sum up B1:B3 if the cells C1:C3 are blank.  This does work in Excel 
but does not work in Open Office.

NOTE:  If you do =if(A2="","IsBlank","IsNotBlank") the "" works to compare for a 
blank cell.  SumIf should do the same.
Comment 1 Oliver Brinzing 2010-12-20 17:28:45 UTC
workaround: =SUMPRODUCT(C1:C3="";B1:B3)
Comment 2 dgm0814 2010-12-21 00:20:16 UTC
This did resolve my issue for new excel documents I create, but does not help 
with documents that are sent to me.

Hopefully this is resolved in a future release as this has caused some problems 
in financial documents that have been sent to me for review.

Thanks for the workaround.
Comment 3 Edwin Sharp 2013-08-22 18:18:36 UTC
Created xls with Excel 2010.
Opened with Rev. 1513819.
=sumif(C1:C3,"",B1:B3) gives 0 instead 21 when C1:C3 are empty and B1:B3=7,7,7.