Issue 116250 - Find by column no longer works after using the FindBar
Summary: Find by column no longer works after using the FindBar
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 3.3 RC7
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: kla
QA Contact: issues@sc
URL:
Keywords:
: 117556 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-12-29 17:44 UTC by sandreas41
Modified: 2017-05-20 10:30 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test doc (7.78 KB, text/plain)
2011-01-27 15:12 UTC, vitriol
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sandreas41 2010-12-29 17:44:21 UTC
Searching by columns no longer works.
Edit.Find, click More Options, click Columns in Search Direction
Expected behavior, to move down the column to the bottom before moving left or
right to next column.
Actual behavior, ignores selection of Column, acts like it always searches by
rows, right before down.

OOo_3.3.0rc7_20101126_Linux_x86_install-rpm_en-US.tar.gz
Comment 1 vitriol 2011-01-26 19:29:30 UTC
Reproducible if you use the FindBar before the normal search by columns. If you
close and reopen the application it works again.
Comment 2 vitriol 2011-01-27 15:12:17 UTC
Steps ti reproduce:

1) Open the attached TestDoc.ods
2) Open Find & Replace > More Options > Search direction:Columns, and search
the word "test". It works OK.
2) Close dialog and use the FindBar to search the word "test" or everything
else.
3) Reopen Find & Replace and redo point 2). The search by columns doesn't work
anymore, an the search is performed by row

Thanks
Comment 3 vitriol 2011-01-27 15:12:58 UTC
Created attachment 75686 [details]
test doc
Comment 4 Andrea Pescetti 2011-02-01 22:52:32 UTC
Confirmed in OOo 3.3.0 final.
Comment 5 niklas.nebel 2011-02-07 13:29:56 UTC
reassigning
Comment 6 niklas.nebel 2011-02-07 13:30:30 UTC
Fixed in CWS "dr78".
Comment 7 vitriol 2011-02-12 13:38:25 UTC
The FindBar also breaks "Search in all tables". Please, check this case too.
Comment 8 niklas.nebel 2011-02-15 12:42:33 UTC
"Search in all sheets" was affected by the same problem, and works again with
the same fix.
Comment 9 vitriol 2011-02-15 12:46:52 UTC
@nn
OK, thank you very much.
Comment 10 niklas.nebel 2011-02-28 18:48:36 UTC
Reassigning to QA for verification.
Comment 11 kla 2011-03-10 12:49:17 UTC
Now it work (and find) as expected -> verified
Comment 12 niklas.nebel 2011-03-28 11:45:47 UTC
*** Issue 117556 has been marked as a duplicate of this issue. ***