Issue 116303 - animation and video transitions
Summary: animation and video transitions
Status: UNCONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: OOO320m18
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-04 23:05 UTC by trebly
Modified: 2013-01-29 21:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Movie created with different ways in presentation with animation order (28.45 KB, application/octet-stream)
2011-09-29 03:02 UTC, halostad
no flags Details
PowerPoint Slide with working Movie with animationorder (66.54 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-09-29 03:03 UTC, halostad
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description trebly 2011-01-04 23:05:10 UTC
Hi,

impress 3.21

I define a slide with two video :
I could not find any way to activate during the show the second( first imported)
video and/or define an order.
The lonely solution has been an automatic transition to a new slide (they must
be chained)

On programming these is clear to understand what have appends. 

When the slide begin the video starts immediately even an animation as been
defined, simple sample : 
1- by a click show the title with an effect
2- Chain to the video

The first idea was to have to video about the same subject
1- by a click show the first title with an effect
2- Chain to the video N°1
3- wait for the second click, then show the second title
4- chain with the video N°2

This don't functions at all :
1- the text of the animation is not displayed
2- the video starts immediately

Best regards

Trebly

nb : a video needs to events : 
1- load but don't start
2- start and/or restart at command
it seems that when the slide is loaded (components) the video starts immediately
then the elements of animation never starts...

nb2 : at the same time my other issue occurs : display on the screen 1 of the
full video and the operator can do nothing else than wait the end, of the video
Comment 1 abertossa2010 2011-09-27 03:27:35 UTC
Alec Bertossa 9/26/11

I was able to replicate this bug using Windows 7 Home Premium with OpenOffice build 9567.

To replicate: 
1) Insert a new slide that can easily hold two videos, like the Title and 2 Content Layout.
2) Insert two different videos into the slide, one for each content window.
3) When the slide comes up while viewing the slide show using the start slide show button or F5, both videos will start automatically.

Impress currently has no way to control when videos start, such as assigning them to start on click. However, PowerPoint 2010 has easily accessible playback options under the video tools tab.

The easiest workaround would be to just separate the videos onto different slides, but this is inconvenient, and could affect how the content of the slide is received.
Comment 2 halostad 2011-09-29 03:02:15 UTC
Created attachment 76847 [details]
Movie created with different ways in presentation with animation order
Comment 3 halostad 2011-09-29 03:03:12 UTC
Created attachment 76848 [details]
PowerPoint Slide with working Movie with animationorder
Comment 4 halostad 2011-09-29 03:05:45 UTC
Hi
I was able to replicate the problem in my Toshiba Satellite Laptop with the following configuration:
OS: Windows 7 Home premium service pack 1 , x64
OOo-Dev3.4 (Dev300m106)
When I replicated the test in different ways the same problem was produced the videos were always started when the slide started even when I add animation order, I even tried to make a PowerPoint presentation that has video that starts after certain order of animations then exported it to impress and in this case it was worst the video was exported as picture and it did not work at all.  
I made the following steps to replicate the problem:

First Way:

1.Open empty slide
2.Add  text to the slide with any custom animation.
3.From menu select Insert  Movie and Sound
4.Go to you movie path then Click Insert.
5.After the Movie inserted to the slide select the movie then Add Custom Animation to the Movie.
6.Select Misc Effect tab, then Click on Start Media and click OK

Second Way:
1.Open empty slide
2.Add  text to the slide with any custom animation.
3.From menu select Tools  Media Player.
4.Small Media Player will open , click on the folder picture.
5.When the video appear click on Stop button.
6.Then click Apply (√), and close the Media Player.
7.Then Add animation to the video to make it start after the Text.

I attached the replication slides and PowerPoint slide that contains a video that starts after certain order.

is seems that this feature does not exist in impress I think it should be a new requirement since its already exists in PowerPoint so users would like their video of exported presentation to work on impress too and even when users create presentations using impress most of the time users would like to make some comments on a video before it started or some time want to show 2 vidoes in the same slide.

Best Regards
Hana Alostad