Issue 116336 - Mail merge - send to multiple files does not work
Summary: Mail merge - send to multiple files does not work
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO330m18
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: 3.4.0
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: regression
: 116662 116986 117284 117642 118155 (view as issue list)
Depends on:
Blocks:
 
Reported: 2011-01-06 18:48 UTC by steverav
Modified: 2014-01-04 12:01 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
database not showing on mail merge prompt (276.98 KB, image/jpeg)
2012-02-22 10:08 UTC, stuupidapp
no flags Details
Test document - Bibliographic database (8.07 KB, application/vnd.oasis.opendocument.text)
2012-02-22 11:13 UTC, Ariel Constenla-Haile
no flags Details
The DataSourceBrowser in the Mail Merge dialog (74.48 KB, image/png)
2012-02-24 08:23 UTC, Ariel Constenla-Haile
no flags Details
The DataSourceBrowser when pressing F4 or menu "View" - "Data Sources" (120.18 KB, image/png)
2012-02-24 08:25 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description steverav 2011-01-06 18:48:05 UTC
I have a mail merge document connected to a open office base query. I tried to
print using the option "print to file" - option Multiple files. This option
prints a single file named as the first record of the query instead of one file
per record.
The same operation works fine when performed with a macro.
Comment 1 eric.savary 2011-01-06 20:34:38 UTC
@HI: Please have a look.
Comment 2 eric.savary 2011-01-06 20:35:36 UTC
Reassigned
Comment 3 h.ilter 2011-01-07 10:32:08 UTC
@OS: Occurs by calling print -> mailmerge
Individual files won't be created, doesn't matter if you create file names from 
database or by your own.
Issue doesn't occur by using the mailmerge-wizard.
Comment 4 eric.savary 2011-01-27 14:21:04 UTC
*** Issue 116662 has been marked as a duplicate of this issue. ***
Comment 5 eric.savary 2011-02-16 23:35:15 UTC
*** Issue 116986 has been marked as a duplicate of this issue. ***
Comment 6 eric.savary 2011-03-09 06:45:09 UTC
*** Issue 117284 has been marked as a duplicate of this issue. ***
Comment 7 vitriol 2011-03-09 06:50:30 UTC
It's a regression from OOo 3.2.1
Comment 8 Oliver Specht 2011-03-15 13:31:38 UTC
Fixed in cws sw34bf05 in
http://hg.services.openoffice.org/cws/sw34bf05/rev/a97679a66c68
Comment 9 Oliver Specht 2011-03-15 14:05:41 UTC
Reviewed by od
Comment 10 Oliver Specht 2011-03-21 10:03:01 UTC
Reassigned for verification
Comment 11 h.ilter 2011-03-23 08:07:39 UTC
Verified with cws sw34bf05 = ok
Comment 12 michael.ruess 2011-04-01 13:49:26 UTC
*** Issue 117642 has been marked as a duplicate of this issue. ***
Comment 13 eric.savary 2011-06-10 12:22:05 UTC
*** Issue 118155 has been marked as a duplicate of this issue. ***
Comment 14 stuupidapp 2012-02-07 08:00:15 UTC
I've just updated to the latest version and I'm having the same problem
Comment 15 mattdeany 2012-02-07 09:57:01 UTC
To say that the mail merge wizard works is a good point, but there are many options available through the print dialogue that is not available via the wizard. I hope that these options are preserved in the fix.
Looking forward to a working print dialogue.
Comment 16 stuupidapp 2012-02-16 08:11:03 UTC
I'm on 3.3.0 build 9567 and I'm still having this problem. Should I open a new ticket?
Comment 17 Ariel Constenla-Haile 2012-02-16 08:25:07 UTC
(In reply to comment #16)
> I'm on 3.3.0 build 9567 and I'm still having this problem. Should I open a new
> ticket?

Can you try with the latest AOO Developer Snapshot from 
https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+3.4+Unofficial+Developer+Snapshots ?
I've tested on Linux x86-64 and this bug seems solved, I cannot reproduce it.
Comment 18 stuupidapp 2012-02-16 15:17:39 UTC
Sorry to sound like a dummy, but what am I doing here, just installing the full installation set from this page? Thanks,
Comment 19 Ariel Constenla-Haile 2012-02-16 17:16:19 UTC
(In reply to comment #18)
> Sorry to sound like a dummy, but what am I doing here, just installing the full
> installation set from this page? Thanks,

Yes, install one of the "Apache OpenOffice - full installation sets" depending on your system. The office installation is in English (user interface - menus, dialogs, help files, etc); you can install a language pack if you need localization in any of the available languages (German, French, Spanish, Italian, Japanese , Chinese, Brazilian, Dutch).

The Developer Snapshot will install like "OOo-Dev", it won't replace your current installation, nor use your current user profile.
Comment 20 stuupidapp 2012-02-22 10:08:45 UTC
Created attachment 77239 [details]
database not showing on mail merge prompt

I've done this, it won't let me view data sources in any form. Please see attached
Comment 21 Ariel Constenla-Haile 2012-02-22 11:13:44 UTC
Created attachment 77240 [details]
Test document - Bibliographic database
Comment 22 Ariel Constenla-Haile 2012-02-22 11:18:24 UTC
(In reply to comment #20)
> Created attachment 77239 [details]
> database not showing on mail merge prompt
> 
> I've done this, it won't let me view data sources in any form. Please see
> attached

This can be a different issue.
Please try with the document in attachment 77240 [details]
Field are attached to the bibliographic database that comes with Apache OpenOffice, so it must work out of the box.
Comment 23 stuupidapp 2012-02-23 09:30:20 UTC
The mail merge prompt is still blank, as per previous attachment
Comment 24 Ariel Constenla-Haile 2012-02-24 08:21:56 UTC
(In reply to comment #23)
> The mail merge prompt is still blank, as per previous attachment

Please check if you can use the Bibliographical database at all:

1. open a Writer document
2. press F4
3. on the left, select "Bibliography", then select "Tables", and finally select the "biblio" table

You should see the content of this table at the right.

What you call the "mail merge prompt" is the DataSourceBrowser component, and is the same when pressing F4 and in the Mail Merge dialog, when printing.
Comment 25 Ariel Constenla-Haile 2012-02-24 08:23:40 UTC
Created attachment 77246 [details]
The DataSourceBrowser in the Mail Merge dialog
Comment 26 Ariel Constenla-Haile 2012-02-24 08:25:36 UTC
Created attachment 77247 [details]
The DataSourceBrowser when pressing F4 or menu "View" - "Data Sources"
Comment 27 stuupidapp 2012-02-24 17:42:03 UTC
I've tried pressing F4 and nothing happens
Comment 28 Ariel Constenla-Haile 2012-02-24 20:52:29 UTC
(In reply to comment #27)
> I've tried pressing F4 and nothing happens

If the DataSourceBrowser doesn't appear by pressing F4 or selecting the menu "View" - "Data Sources", then something is wrong with your installation; I wonder if you are even able to create a database at all (menu File - New - Database) because the database module seems to be missing or broken in your installation.

Reinstalling AOO may fix your issue.
Comment 29 helmetzer 2012-06-20 08:21:20 UTC
Now waiting for more than a year, I went away to LibreOffice. Bye bye.
Comment 30 Ariel Constenla-Haile 2012-06-20 15:52:41 UTC
Closing as irreproducible
Comment 31 mattdeany 2013-06-03 14:23:25 UTC
(In reply to Ariel Constenla-Haile from comment #28)
> (In reply to comment #27)
> > I've tried pressing F4 and nothing happens
> 
> If the DataSourceBrowser doesn't appear by pressing F4 or selecting the menu
> "View" - "Data Sources", then something is wrong with your installation; I
> wonder if you are even able to create a database at all (menu File - New -
> Database) because the database module seems to be missing or broken in your
> installation.
> 
> Reinstalling AOO may fix your issue.

For many of us, the whole issue of Java has been a problem. Many things function correctly without a version of Java being overtly selected. Some of my problems went away when I chose a version within Tools>Options>OpenOffice.org>Java. This is not a flagged up issue for most, but seems to affect mail merge. Perhaps the problem was to do with Java selection?
Comment 32 Rainer Bielefeld 2014-01-04 12:01:10 UTC
I did a quick test with server installation of "AOO 4.1.0-Dev – English  UI / English locale - [AOO410m1(Build:9750)  -  Rev. 1554205 - 2014-01-01]" on German WIN7 Home Premium (64bit)", own separate user profile, Java 1.7.0_25 selected. 
4 Tried to "print to file"  4 .odt documents from biblio database. Worked fine, even without active JRE.
With OOo 3.3.0 i did not get that function working with Java (only 1.6 available) or without: always all pages will be "printed" into a single .odt document.

So I am pretty sure that this one really has been fixed.

If someone still observes a problem here with 4.0.1 or later he should please submit a new Bug report with a precise step by step instruction.