Issue 116606 - Custom animation looks different depending on prehistory
Summary: Custom animation looks different depending on prehistory
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 3.2.1
Hardware: PC Windows 7
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-25 15:33 UTC by lyumar
Modified: 2017-05-20 11:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
An example presentation with this issue: "Spin" effects on two ellipses look different (10.85 KB, application/vnd.sun.xml.impress)
2011-01-25 15:35 UTC, lyumar
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lyumar 2011-01-25 15:33:11 UTC
Steps to reproduce
1.	Create new presentation
2.	Draw a shape – for example a simple ellipse
3.	Enter some text in the shape
4.	Add “Spin” custom animation to the shape (context menu --> Custom Animation…
--> Add… --> “Emphasis” tab --> Spin --> OK)
5.	Repeat steps 2-3 for another shape
6.	Add “Shimmer” custom animation to the second shape
7.	Change animation effect for the second shape to “Spin” (select the shape -->
Custom animation pane --> Change… --> “Emphasis” tab --> Spin --> OK)
8.	Press F5 and play animation for both shapes

Actual result: Animation for two shapes differs: the first shape spins itself
but in the second shape only text spins.

In general, if I change “shape” effect to “text” effect it still is applied to
the whole shape, and vice versa.

“Text” effects: shimmer, wave, grow with color, color over by letter, and color
over by word.

“Shape” effects (all emphasis effects that could be applied to a shape without
text): change fill/line color, spin, transparency, color blend,
complementary/contrasting color, desaturate, flash bulb, lighten, blast, blink,
flicker, and teeter.

Notes:
1.	Workaround is quite simple: do not change the animation, just remove it and
add new one.
2.	The same problem for all kinds of shapes with text (even lines)
3.	The same problem in DEV300m97
Comment 1 lyumar 2011-01-25 15:35:27 UTC
Created attachment 75641 [details]
An example presentation with this issue: "Spin" effects on two ellipses look different
Comment 2 wolframgarten 2011-01-26 07:34:17 UTC
Reproducible. Reassigned.
Comment 3 groucho266 2011-01-26 09:18:13 UTC
Changing the animation from Shimmer to Spin apparently does change the type of
text animation (entry "Text animation" on the "Effect" tab of the Effect Options
dialog) from "Letter by letter" back to "All at once".

@cl: Is that a bug or a feature?
Comment 4 Marcus 2017-05-20 11:33:41 UTC
Reset assigne to the default "issues@openoffice.apache.org".