Issue 116610 - Copy and pasting from client to host using remote desktop client in windows results in crash.
Summary: Copy and pasting from client to host using remote desktop client in windows r...
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO320m18
Hardware: PC Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact: Alex
Depends on:
Reported: 2011-01-25 16:29 UTC by mandamus
Modified: 2014-04-02 13:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description mandamus 2011-01-25 16:29:31 UTC
Using remote desktop and running OO Base on host machine.
When copying and pasting from client machine to host machine OO Base crashes to 

specific incident. When I copy an SQL string locally, and paste it into the RDP 
session into the query designer in OO Base, OO Base crashes hard. Every time. 
there has been no variation in this behavior for several versions of OO Base 
and several client installations of windows from XP to 7.  The Host has been 
windows server 2003. 

However. If I first copy the text into Notepad on the host, and then copy THAT 
and paste it into Base on the host, it works fine.  So there's no issues with 
the connecting cliboards. or the local clipboard on the host. 

for S&G I just tried to paste text from my client into Writer on the host. It 
also failed, but didn't crash. It gave me the error message "Requested 
Clipboard format is not available". 

I also tried paste special as unformatted text. same result. Same success when 
pasting into notepad on the host, and then copying that and pasting into 
Comment 1 mandamus 2011-01-25 17:34:35 UTC
Local machine, copied Excel cells from excel 2010 and pasted them into calc on 
the remote machine, and it worked. 

Tried copying flat text locally and pasting that into a cell in Calc on the 
remote machine, got the error message "The contents of the clipboard could not 
be pasted"

Again, Copying into notepad on the remote machine then copying and pasting that 
into a cell worked fine. 
Comment 2 r4zoli 2011-01-26 08:10:34 UTC
This issue tracker for submitting bugs, not for support questions.
Please follow basic rules:
You may ask your questions on or on community forum:
Comment 3 mandamus 2011-01-26 14:31:12 UTC
Crashing to desktop is not a bug? 

Funny. I thought it was a bug. 

Is it supposed to do that? 

Comment 4 r4zoli 2011-01-27 07:55:02 UTC
Test it with OOo 3.3 the issue still happens?
Lots of bugfixes maybe solved your problem.

The OOo 3.2.1 issues will be fixed only if it reproducible in latest OOo version.
Comment 5 ocke.janssen 2011-01-27 08:09:15 UTC
Could you please have a lool at this? Thanks.
Comment 6 philipp.lohmann 2011-02-08 14:31:34 UTC
Resetting target accroding to new task handling scheme announced here:
Comment 7 Rob Weir 2013-07-30 02:22:23 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.
Comment 8 kev 2014-04-02 12:45:44 UTC
The part about pasting plain text still happens on 4.0.1.  I can't even paste a single cell, in the input area or just having selected a cell.  In fact, if I use the keyboard Ctrl+V, I don't even get the error message, just nothing happens.

Ideally, one should be able to copy tab-delimited text, and paste it on any cell, and have the tabs and newlines determine what ends up in which cell.  Currently to do this you have to create a new document.
Comment 9 kev 2014-04-02 13:06:42 UTC
The odd thing is, you can freely accomplish all this via drag 'n' drop.  But IMHO drag 'n' drop and copy 'n' paste should function the same way, but maybe I'm ignorant of something here.