Issue 116723 - DOC to PDF conversion and MS Office 2007
Summary: DOC to PDF conversion and MS Office 2007
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.2.1
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 10:59 UTC by santeos
Modified: 2020-12-15 14:11 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word document 2007 (58.80 KB, application/msword)
2011-01-31 16:43 UTC, santeos
no flags Details
PDF Document (29.79 KB, application/pdf)
2011-01-31 16:44 UTC, santeos
no flags Details
docx exported to PDF with AOO 4.1.8 (70.19 KB, application/pdf)
2020-12-12 20:55 UTC, Matthias Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description santeos 2011-01-31 10:59:50 UTC
Hello, 

We use conversion DOC to PDF provided by Open Office 3.2.1

It works well when using Word 2003. 
But, with Word 2007, some document DOC are not converted correctly. 
For instance, a document where figure a table containing a table is not
correctly converted (the page layout is not correct). 

Is the next Open Office version correct these conversion problems with MS Office
2007 (and 2010) ? 

Thank you in advance for your help and contribution.
Comment 1 Marcus 2011-01-31 16:36:03 UTC
please attach a .doc document that doesn't get converted to .pdf correctly, then
we can analyze the issue, otherwise it's not possible to give you a statement if
an issue is fixed
Comment 2 santeos 2011-01-31 16:43:55 UTC
Created attachment 75732 [details]
Word document 2007
Comment 3 santeos 2011-01-31 16:44:45 UTC
Created attachment 75733 [details]
PDF Document
Comment 4 santeos 2011-01-31 16:46:21 UTC
I added 2 files : 
- the first Test2007.docx is the original Word document
- The second Test2007.pdf is the PDF document after the conversion

Thank you in advance for your help and contribution.
Comment 5 santeos 2011-02-11 11:29:48 UTC
Hello, 

Did you manage to reproduce the conversion problem ?
Please, could you give us a statement about this issue.

Regards
Comment 6 ab 2011-02-11 11:41:45 UTC
ab->os: Please have a look
Comment 7 Oliver Specht 2011-02-11 14:43:24 UTC
reassigned
Comment 8 santeos 2011-02-28 08:41:17 UTC
(In reply to comment #6)
> ab->os: Please have a look

Hello, 

Please, could you give us a statement about this issue.

Regards
Comment 9 openoffice 2011-02-28 10:57:20 UTC
Analysis: DEV300_m100 reads table structure correctly. However the images (v:shape) are not imported.
Comment 10 santeos 2011-03-15 10:49:32 UTC
Hello, 

I don't understand completely your last comment.
Could you give us more information about your analysis ?
Thanks in advance.

Regards
Comment 11 openoffice 2011-03-15 11:13:24 UTC
For further information what DEV300_m100 is please see here:
http://development.openoffice.org/releases/DEV300m100_snapshot.html

v:shape is an XML-Tag used OOXML:

http://www.ecma-international.org/publications/standards/Ecma-376.htm
Comment 12 santeos 2011-05-02 14:17:33 UTC
Hello, 

If a understand well, in DEV300_m100, table structure is read correctly (it correct our bug) but the images (v:shape) are not imported.

My question : I suppose DEV300_m100 will correspond to a newer version of OpenOffice. When the next version of OpenOffice will be released ?

Thanks in advance.

Regards
Comment 13 santeos 2011-07-12 13:40:30 UTC
Hello, 

Please, could you give us a statement about this issue.

Regards
Comment 14 Marcus 2017-05-20 11:15:20 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 15 oooforum (fr) 2018-12-12 20:08:02 UTC
*** Issue 127952 has been marked as a duplicate of this issue. ***
Comment 16 Matthias Seidel 2020-12-12 20:54:24 UTC
I just exported the docx with AOO 4.1.8 as PDF and the result looks identical to what I see in Writer.
Comment 17 Matthias Seidel 2020-12-12 20:55:06 UTC
Created attachment 86993 [details]
docx exported to PDF with AOO 4.1.8
Comment 18 Keith N. McKenna 2020-12-14 01:40:29 UTC
(In reply to Matthias Seidel from comment #16)
> I just exported the docx with AOO 4.1.8 as PDF and the result looks
> identical to what I see in Writer.

What OS did you do create the PDF on? I just repeated your test on Windows 10 with the same result.
Comment 19 Matthias Seidel 2020-12-14 15:34:56 UTC
My export was on Ubuntu 16.04 with AOO 4.1.8
I now did an export on Windows 10 with AOO 4.5.0-dev and had the same result.
Comment 20 Keith N. McKenna 2020-12-14 19:33:05 UTC
(In reply to Matthias Seidel from comment #19)
> My export was on Ubuntu 16.04 with AOO 4.1.8
> I now did an export on Windows 10 with AOO 4.5.0-dev and had the same result.

Thanks Matthias this gives us a firm commitment that it is not just  a Linux Issue.
Comment 21 Matthias Seidel 2020-12-15 00:38:17 UTC
So the issue seems to have been fixed in the last 9 years... ;-)
Comment 22 Keith N. McKenna 2020-12-15 01:37:29 UTC
(In reply to Matthias Seidel from comment #21)
> So the issue seems to have been fixed in the last 9 years... ;-)

So it would seem. I am tempted to mark this closed fixed. Would you concur?
Comment 23 Matthias Seidel 2020-12-15 09:07:08 UTC
(In reply to Keith N. McKenna from comment #22)
> (In reply to Matthias Seidel from comment #21)
> > So the issue seems to have been fixed in the last 9 years... ;-)
> 
> So it would seem. I am tempted to mark this closed fixed. Would you concur?

Since we cannot reproduce it anymore, I would think we can close this one.

However, this was marked as duplicate of:

https://bz.apache.org/ooo/show_bug.cgi?id=127952

which is still reproducible for me.
Comment 24 Keith N. McKenna 2020-12-15 13:15:38 UTC
(In reply to Matthias Seidel from comment #23)
> (In reply to Keith N. McKenna from comment #22)
> > (In reply to Matthias Seidel from comment #21)
> > > So the issue seems to have been fixed in the last 9 years... ;-)
> > 
> > So it would seem. I am tempted to mark this closed fixed. Would you concur?
> 
> Since we cannot reproduce it anymore, I would think we can close this one.
> 
> However, this was marked as duplicate of:
> 
> https://bz.apache.org/ooo/show_bug.cgi?id=127952
> 
> which is still reproducible for me.

Looking at Bugzilla the 2 bugs are no longer marked as duplicates as indeed they are not. Given that it appears as it is safe to close this one.
Comment 25 Matthias Seidel 2020-12-15 14:11:16 UTC
I already removed the false duplicate.

Closing this one as fixed.