Issue 116813 - [sfx2] complex.sfx2.UndoManager checkBrokenScripts fails
Summary: [sfx2] complex.sfx2.UndoManager checkBrokenScripts fails
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: scripting (show other issues)
Version: DEV300m99
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Frank Schönheit
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-04 17:00 UTC by mst.ooo
Modified: 2013-08-07 15:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mst.ooo 2011-02-04 17:00:28 UTC
in a unxsoli4.pro build of gnumake3 the complex test UndoManager reproducibly fails:

2) checkBrokenScripts(complex.sfx2.UndoManager)
java.lang.AssertionError: clicking the test button did not work as expected -
basic script not called
        at org.junit.Assert.fail(Assert.java:91)
        at org.junit.Assert.assertTrue(Assert.java:43)
        at complex.sfx2.UndoManager.checkBrokenScripts(UndoManager.java:194)

for now i'll disable the checkBrokenScripts test.
Comment 1 Frank Schönheit 2011-03-29 10:00:25 UTC
hmm - cannot reproduce in DEV300m104. Running "make subsequentcheck" in sfx2, with UndoManager.checkBrokenScripts re-enabled, works like a charm, multiple times in a row.
Comment 2 Frank Schönheit 2011-03-29 10:01:34 UTC
closing