Issue 11686 - Javac breaks in UTF-8 locales, eg. default RH 8.0
Summary: Javac breaks in UTF-8 locales, eg. default RH 8.0
Status: CLOSED FIXED
Alias: None
Product: Build Tools
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.2
Hardware: PC Other OS
: P2 Trivial (vote)
Target Milestone: OOo 1.1 Beta2
Assignee: jens-heiner.rechtien
QA Contact: issues@tools
URL:
Keywords:
: 6918 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-02-20 15:55 UTC by mmeeks
Modified: 2003-05-20 11:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mmeeks 2003-02-20 15:55:07 UTC
Net effect can't compile:
eg. in: sandbox/com/sun/star/lib/sandbox/generic

-bash-2.05b$ export LANG=C
-bash-2.05b$ javac -classpath ... Dispatcher.java ConstantPool.java
DispatcherAdapterBase.java DispatcherAdapterFactory.java IInvokeSec.java
-bash-2.05b$
-bash-2.05b$ export LANG=en_US.UTF-8
-bash-2.05b$ javac -classpath ... Dispatcher.java ConstantPool.java
DispatcherAdapterBase.java DispatcherAdapterFactory.java IInvokeSec.java
error: compiler message file broken:
key=compiler.err.sun.io.MalformedInputException arguments=null, null, null,
null, null,
null, null
error: compiler message file broken:
key=compiler.err.sun.io.MalformedInputException arguments=null, null, null,
null, null,
null, null
error: compiler message file broken:
key=compiler.err.sun.io.MalformedInputException arguments=null, null, null,
null, null,
null, null
error: compiler message file broken:
key=compiler.err.sun.io.MalformedInputException arguments=null, null, null,
null, null,
null, null
4 errors

Presumably the configure script / LinuxIntelEnv.Set needs to clobber LANG [suckage]
Comment 1 mmeeks 2003-02-21 10:46:48 UTC
Apparently the .java files are in some 8bit locale; the compiler needs
to know about this:

| javac -help
| Usage: javac <options> <source files>
| where possible options include:
| ...
|   -encoding <encoding>      Specify character encoding used by
source files

Should we be setting the encoding ?
Comment 2 jens-heiner.rechtien 2003-04-08 16:34:21 UTC
Hi Michael,

no wonder javac breaks in the UTF8 locale. At least ConstantPool.java
(I haven't checked the others) still contains german "Umlaute",
encoded in iso-latin1. I would really prefer to clean this up, sources
(with the exception of the *.src files) should be plain ascii, nothing
else. I prefer to just clean up the sources.

Stefan agreed to take this one.

Reassign to Stefan.
Comment 3 Stephan Bergmann 2003-04-09 10:35:49 UTC
cleaned up source code
Comment 4 jens-heiner.rechtien 2003-04-11 13:11:10 UTC
*** Issue 6918 has been marked as a duplicate of this issue. ***
Comment 5 Stephan Bergmann 2003-04-23 14:12:06 UTC
...got relocated to CWS ooo20030412.
Comment 6 Stephan Bergmann 2003-04-24 10:10:34 UTC
Please check on ooo20030412 and set to verified.
Comment 7 mmeeks 2003-05-02 17:44:50 UTC
Since I can't verify this just now; any chance you can Jens ?
Comment 8 Martin Hollmichel 2003-05-09 11:40:21 UTC
fixed on beta2 branch.
Comment 9 Martin Hollmichel 2003-05-09 11:40:47 UTC
fixed.
Comment 10 jens-heiner.rechtien 2003-05-20 11:50:47 UTC
Verified.

Closing.