Issue 116958 - Zoom Slider Control Responds without Mouse Down Event
Summary: Zoom Slider Control Responds without Mouse Down Event
Status: CLOSED DUPLICATE of issue 116700
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOO320m18
Hardware: PC Windows 7
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 113828 (view as issue list)
Depends on:
Blocks:
 
Reported: 2011-02-14 16:16 UTC by jimofcr
Modified: 2017-05-20 09:52 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jimofcr 2011-02-14 16:16:31 UTC
I believe that UI controls should only respond when they receive a mouse down 
event. The zoom control of OOo320m18 Build 9502 (OpenOffice.Ord 3.2.1) responds 
to a mouse up event when the mouse pointer drifts over the control after a 
mouse down event has happened over the horizontal scroll bar. This continually 
causes havic on a very large spreadsheet on a large monitor with a tiny mouse 
pointer. Carefully following a row as one scrolls for dozens of columns only to 
have the sheet explode or disappear causes great confusion ... and it happens 
several times per hour of use. Although the idea behind the scroll widget is 
really great, I would gladly disable it if I could until it is fixed.

TO REPRODUCE:
This will work best on a wide-screen monitor of at least 22" with the 
spreadsheet set to full-screen.
1. Create a spreadsheet with at least 500 columns (the number of rows is 
unimportant)
2. Starting with the scroll thumb under column 1, drag the thumb all the way to 
the right - do not release the mouse button.
3. Move the mouse pointer down until it is hovering over the zoom control.
4. Release the mouse button.
--> If the pointer was over the zoom control to the left or to the right of the 
current position of the zoom slider, the spreadsheet will change the zoom 
factor accordingly and instantly.
Comment 1 Edwin Sharp 2013-12-04 15:20:54 UTC
Outcome is expected when mouse is not released in step 2.
Comment 2 Edwin Sharp 2013-12-04 20:53:07 UTC
Recheck and comparison to Excel 2010.
Comment 3 Edwin Sharp 2013-12-04 20:54:19 UTC
Zoom slider is wrongfully affected.

AOO410m1(Build:9750)  -  Rev. 1543812
Rev.1543812
Win 7
Comment 4 Edwin Sharp 2013-12-09 20:36:22 UTC
*** Issue 113828 has been marked as a duplicate of this issue. ***
Comment 5 mroe 2014-08-24 07:00:17 UTC
see issue 116700.

*** This issue has been marked as a duplicate of issue 116700 ***