Issue 1171 - handling of overlapping cell boundaries different to Excel (alignment - left justified)
Summary: handling of overlapping cell boundaries different to Excel (alignment - left ...
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 632
Hardware: All All
: P3 Trivial with 18 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa
: 3387 4368 4486 4597 4637 4742 6252 7151 8214 10639 11165 11193 11481 12314 14574 15801 19676 19747 19748 20101 20812 25600 29079 32045 35332 37471 42788 49182 50489 (view as issue list)
Depends on:
Blocks:
 
Reported: 2001-07-04 23:55 UTC by issues@www
Modified: 2013-08-07 15:15 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Publicly available cub scout tracking spread sheet showing the problem (click on 'Scout 1' tab and the problem is pretty obvious) (610.50 KB, application/vnd.ms-excel)
2003-12-10 03:55 UTC, jeremypwhite
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description issues@www 2001-07-04 23:55:28 UTC
OpenOffice currently display's fields which are too large by displaying part of
the field, and a little arrow to indicate there is more data. It would be nice
if it would attempt to display the contents anyway, ala Excel.
Also the alignment of the text which is displayed is unpredictable.
For example, say I have a column total is given a title, (Total Sales This
Month) and I try to right-align the text so that it just reaches the next field.
Doesn't work. It displays Total S> (where the > is the little arrow). Even when
the field is expanded to be large enough to properly display the text, the
right-alignment never happens.
Good luck whoever works on it!
Great work so far...

Dan
Comment 1 frank 2001-07-05 08:44:20 UTC
.
Comment 2 falko.tesch 2001-09-17 14:24:21 UTC
The alignment is already on our agenda. The red arrow is intrduced to 
make all tables more readable.
Comment 3 Unknown 2001-11-08 23:05:55 UTC
changing QA contact from bugs@ to issues@
Comment 4 peter.junge 2002-03-07 16:40:04 UTC
*** Issue 3387 has been marked as a duplicate of this issue. ***
Comment 5 peter.junge 2002-03-11 15:49:36 UTC
*** Issue 3387 has been marked as a duplicate of this issue. ***
Comment 6 frank 2002-05-02 08:02:52 UTC
*** Issue 4368 has been marked as a duplicate of this issue. ***
Comment 7 frank 2002-05-06 07:42:32 UTC
*** Issue 4486 has been marked as a duplicate of this issue. ***
Comment 8 frank 2002-05-07 15:03:30 UTC
*** Issue 4597 has been marked as a duplicate of this issue. ***
Comment 9 frank 2002-05-08 13:22:28 UTC
*** Issue 4637 has been marked as a duplicate of this issue. ***
Comment 10 frank 2002-05-13 08:42:32 UTC
*** Issue 4742 has been marked as a duplicate of this issue. ***
Comment 11 frank 2002-07-03 09:01:06 UTC
*** Issue 6252 has been marked as a duplicate of this issue. ***
Comment 12 prgmgr 2002-08-21 03:57:05 UTC
*** Issue 7151 has been marked as a duplicate of this issue. ***
Comment 13 daniel.rentz 2002-10-14 10:46:01 UTC
*** Issue 8214 has been marked as a duplicate of this issue. ***
Comment 14 frank 2003-01-14 09:57:34 UTC
*** Issue 10639 has been marked as a duplicate of this issue. ***
Comment 15 daniel.rentz 2003-02-04 07:26:27 UTC
*** Issue 11165 has been marked as a duplicate of this issue. ***
Comment 16 daniel.rentz 2003-02-05 13:04:26 UTC
*** Issue 11193 has been marked as a duplicate of this issue. ***
Comment 17 daniel.rentz 2003-02-17 10:58:15 UTC
*** Issue 11481 has been marked as a duplicate of this issue. ***
Comment 18 t8m 2003-03-15 12:26:43 UTC
What's the progress on this issue? I think that by duplicating all
these various issues to this bug it becomes a little bit uncertain
what is already resolved and what not.
Comment 19 reedstrm 2003-04-07 18:08:26 UTC
This bug is one of the last major incompatabilities with MS Excel
spreadsheets. Lots of people use Excel as a layout engine for data
entry forms, these days. Opening one of those forms in oocalc is ... ugly.

I note that the behavior still exists in 1.1beta.

Ross
Comment 20 daniel.rentz 2003-04-28 08:45:51 UTC
*** Issue 12314 has been marked as a duplicate of this issue. ***
Comment 21 daniel.rentz 2003-05-19 15:43:52 UTC
*** Issue 14574 has been marked as a duplicate of this issue. ***
Comment 22 daniel.rentz 2003-06-19 09:56:24 UTC
*** Issue 15801 has been marked as a duplicate of this issue. ***
Comment 23 alex.thurgood 2003-07-10 18:06:48 UTC
This seems to be one of those RFEs that's never going to get off the
ground. If you want things to change, then you need to draw the OOo
developers' attention to the priority that this feature has for you.
The only way to to this at the moment is to vote on it. Since the RFE
only has 9 votes, those little reminder bells we all love to hate
aren't going off on the developers workstation.

If you want it prioritized from your point of view, vote on it. This
doesn't mean that more ressources will be allotted though - the voting
system doesn't unfortunately work that way (which is a shame I admit),
but at least you will raise the profile of the issue.

Alex.
Comment 24 lohmaier 2003-07-15 00:02:21 UTC
setting target-milestone. changed summary (original: Multiple Text
Alignment issues) - no wonder why there are so many duplicates...
Platform, OS -> ALL
Comment 25 rtrout 2003-07-15 01:05:39 UTC
Actually there are two reasons why there are so many dupes - finding
the issue (your summary may improve it) and the fact that the bug is
so annoying and has been around so long. In terms of round-tripping
documents between Excel and OOO this is one of the most glaringly
obvious still remaining. Have you noticed the ago of this bug? Happy
second birthday to bug 1171!

In fact now that the MS Excel import/export filters are so good,
perhaps this bug should be changed from Enhancement to DEFECT. Most of
the dupe bugs were entered as defects. How about the change?
Comment 26 daniel.rentz 2003-07-15 11:58:18 UTC
There is work in progress in conjunction with mirrored sheets.
Comment 27 falko.tesch 2003-09-10 14:01:48 UTC
Hi Daniel, since you are ahead of Excel interoperability you have way
better overview when and what of this issue makes it into 2.0
Thus I re-assign it you.
Comment 28 daniel.rentz 2003-09-15 09:02:03 UTC
The Excel import filter works correctly, the Calc layout is the 
problem. Niklas is working on this issue.
Comment 29 daniel.rentz 2003-09-18 10:26:10 UTC
*** Issue 19676 has been marked as a duplicate of this issue. ***
Comment 30 frank 2003-09-18 11:37:55 UTC
*** Issue 19748 has been marked as a duplicate of this issue. ***
Comment 31 niklas.nebel 2003-09-19 15:00:28 UTC
accepting.
Comment 32 frank 2003-09-26 08:40:10 UTC
*** Issue 20101 has been marked as a duplicate of this issue. ***
Comment 33 frank 2003-10-07 07:52:07 UTC
*** Issue 20812 has been marked as a duplicate of this issue. ***
Comment 34 frank 2003-10-28 13:27:11 UTC
*** Issue 19747 has been marked as a duplicate of this issue. ***
Comment 35 rtrout 2003-12-09 23:03:48 UTC
I just received a note from Niklas Nebel on the sc-features list that this had
just been fixed on 680 as part of doing right-to-left layout. Can anyone confirm
that this fix is working and applies to this issue? If it is fixed in a 680
developer release, how should the status be updated? (
Comment 36 jeremypwhite 2003-12-10 03:53:37 UTC
I've just retested this on a cub scout tracking spread sheet
that I use in which it fails (and which I'll attach in a moment).

It still fails with build 680.
Comment 37 jeremypwhite 2003-12-10 03:55:54 UTC
Created attachment 11849 [details]
Publicly available cub scout tracking spread sheet showing the problem (click on 'Scout 1' tab and the problem is pretty obvious)
Comment 38 niklas.nebel 2003-12-10 17:59:47 UTC
Yes, this issue is fixed with the "calcrtl" child workspace (branch).
There is no build available yet. The fix first has to be approved by QA before
it can be integrated into the main development version.
I'm reassigning this issue to QA, so they can verify it is fixed.
Quite impressive example, by the way, I haven't seen one before where the text
alignment made such a huge difference.
Comment 39 oc 2004-01-06 14:04:40 UTC
Set resolution to fixed
Comment 40 oc 2004-01-19 14:02:07 UTC
Verified in internal build cws_calcrtl
Comment 41 frank 2004-02-17 13:21:54 UTC
*** Issue 25600 has been marked as a duplicate of this issue. ***
Comment 42 oc 2004-02-26 09:47:30 UTC
Fix available in developer snapshoot OOo680m26
Comment 43 daniel.rentz 2004-05-26 13:21:42 UTC
*** Issue 29079 has been marked as a duplicate of this issue. ***
Comment 44 frank 2004-07-23 22:08:26 UTC
*** Issue 32045 has been marked as a duplicate of this issue. ***
Comment 45 frank 2004-10-12 08:04:36 UTC
*** Issue 35332 has been marked as a duplicate of this issue. ***
Comment 46 frank 2004-11-19 16:07:28 UTC
*** Issue 37471 has been marked as a duplicate of this issue. ***
Comment 47 frank 2005-02-15 09:50:51 UTC
*** Issue 42788 has been marked as a duplicate of this issue. ***
Comment 48 psfales 2005-02-15 14:53:33 UTC
Since this issue seems to impacting a lot of people, I thought I would share the
workaround.   It works for the Scout tracker mentioned in several of the
comments and probably others as well.

If, say, C3 is the right-aligned cell which is being truncated, you can create
a "merged cell" by selecting the truncated cell along with one or more cells to
the left (e.g. B3 and A3) then Format->Merged Cells->Define.   The full text is
visible in the larger "merged" cell.

The same mechanism works in Excel.  I've reported this to the author of the
Scout tracker and since the change will still work in both Excel and OO I
believe she plans to implement this change in a future release of the tracker.   
Comment 49 rtrout 2005-02-15 21:47:13 UTC
Yes, this is a workaround (and I'm surprise it hasn't been mentioned here
previously).

However some users don't like merged cells (it can make other actions more
difficult or impossible).

But for the average user the problem is that it is not like Excel.

I guess this is the sort of bug that appears trivial to a programmer, but is a
usability problem for the average office worker.
Comment 50 bjohnsonoo 2005-02-15 23:34:15 UTC
The reason that this is a problem for the average office worker is that they
have to remember to go through and visually check cells with right alignment to
make sure that they are not truncated.

And with spreadsheets with varying data in cells, visually checking them in one
condition may not catch all the truncated cells in ALL conditions.

Comment 51 daniel.rentz 2005-05-13 08:29:17 UTC
*** Issue 49182 has been marked as a duplicate of this issue. ***
Comment 52 frank 2005-06-16 11:40:50 UTC
*** Issue 50489 has been marked as a duplicate of this issue. ***