Issue 117267 - OOo not printing on page size A5
Summary: OOo not printing on page size A5
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.3
Hardware: Mac Mac OS X 10
: P3 Normal (vote)
Target Milestone: 3.4.0
Assignee: gsldev
QA Contact: issues@framework
URL:
Keywords:
: 117270 (view as issue list)
Depends on:
Blocks:
 
Reported: 2011-03-07 18:56 UTC by micha-2010
Modified: 2017-05-20 10:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Expected page format is Din A5 (114.75 KB, image/png)
2011-03-10 14:16 UTC, h.ilter
no flags Details
Page view is driver depended (107.38 KB, image/png)
2011-03-11 11:08 UTC, h.ilter
no flags Details
PDF created of an A5 document with the printer driver (274.94 KB, application/pdf)
2011-03-11 15:57 UTC, micha-2010
no flags Details
document exported as PDF (not printed!) (86.28 KB, application/pdf)
2011-03-11 15:58 UTC, micha-2010
no flags Details
Printer Settings Dialoge of Kyocera Printer (42.44 KB, image/png)
2011-03-11 19:37 UTC, micha-2010
no flags Details
OOo uses A5 in 3.2.1 (95.81 KB, image/png)
2011-03-11 19:39 UTC, micha-2010
no flags Details
same document print dialoge in OOo 3.3 (65.48 KB, image/png)
2011-03-11 21:41 UTC, micha-2010
no flags Details
print dialog in OOo 3.2.1 with custom page size (112.85 KB, image/png)
2011-03-12 09:16 UTC, micha-2010
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description micha-2010 2011-03-07 18:56:08 UTC
When selecting a page size of A5 the printer does not use this paper size for printing but "letter" (on Win) or "A4" (on Mac) instead. Page Sizes of A4, A3, B5 etc are all correctly used, as far as I have tested, only A5 not more in version 3.3 of OOo. OOo 3.2.1 is working correctly. I tested on Mac and on Windows and I tested even OOo-dev 330m101.
I could not find any issue that describes this problem until now. I am using a german version of OOo.
Comment 1 Olaf Felka 2011-03-08 06:54:16 UTC
@ hi: Please have a look
Comment 2 h.ilter 2011-03-10 14:16:08 UTC
Created attachment 76071 [details]
 Expected page format is Din A5

The page preview shows wrong page format, Din-A4 instead Din-A5.
Therefore, Din-A5 seems to be not supported
Comment 3 h.ilter 2011-03-10 14:17:37 UTC
@PL: Please add this issue to vcl120 if possible.
Comment 4 michael.ruess 2011-03-10 14:53:17 UTC
*** Issue 117270 has been marked as a duplicate of this issue. ***
Comment 5 philipp.lohmann 2011-03-11 10:17:42 UTC
So what printer driver did you use ? Because if the driver does not say "A5 available", you'll never get A5.
Comment 6 h.ilter 2011-03-11 11:05:54 UTC
@PL: In short printing to a Din A5 paper works
You are right about the driver
See my second attachment
But what can we do to avoid being misled
Comment 7 h.ilter 2011-03-11 11:08:28 UTC
Created attachment 76077 [details]
Page view is driver depended
Comment 8 micha-2010 2011-03-11 12:46:00 UTC
All my drivers have A5 as paper size available - and OOo 3.2.1 is currently printing on this paper with the same documents OOo 3.3 does not. I also tested various drivers: Oki C530, Kyocera KM4035, Canon Pixma 4300. So it is not a problem of the driver i think, but a problem how OOo selects the paper size of the driver.
I did another test and changed the page size in the Format-page dialoge. When I select a height of 20,9 cm A5 is used in the printer, with a height of 20,95 cm or 21,0 (that is A5) A4 is used instead.
And another fact, it is not textdocument specific but the same occurs when I use spreadsheets.
Comment 9 h.ilter 2011-03-11 13:34:57 UTC
I did the print test with OOO330m17 & current DEV300m102 on MAC OS X 10.6.6 and could not find any problem for the print result. And yes, I've used DIN A5 paper.

@remi1975: Please provide your sample file and your print result as ps or pdf file. Could be helpful to evaluate.
Comment 10 micha-2010 2011-03-11 15:57:34 UTC
Created attachment 76080 [details]
PDF created of an A5 document with the printer driver

this is how the document is printed (page size in the document is A5) - Openoffice 3.3 was used and the OKI C530 printer as default
Comment 11 micha-2010 2011-03-11 15:58:57 UTC
Created attachment 76081 [details]
document exported as PDF (not printed!)

this is the same document, but "export as pdf" was used.
Comment 12 philipp.lohmann 2011-03-11 16:26:23 UTC
At least the kyocera printer does not have A5 defined as a paper format. Therefore I think this is a duplicate to issue 113562; an option should be introduced to print to a paper format regardless what the printer driver may or may not advertise. This is kind of what we did in 3.2 where we simply set the page output size as paper format (resulting in a user defined page size on many printers) which in these cases is probably what you want. Nowadays the new dialog wants to present the most likely output and tries to ask the printer what paper it actually can use and if that does not include the needed paper format, you end up with a different paper that will fit the printed size (A4 being the default format).

*** This issue has been marked as a duplicate of issue 113562 ***
Comment 13 micha-2010 2011-03-11 19:37:53 UTC
Created attachment 76085 [details]
Printer Settings Dialoge of Kyocera Printer

I am sorry, but I have to contradict, the Kyocera also has A5 as a Paper size available - as all other printers have - you can see this in the paper settings dialoge of another Mac application.
And in OOo 3.2.1 there is not a user defined paper size used to print the document, but it is used A5 (I will add another picture where it can be seen in the print dialoge of OOo 3.2.1 itself!) And - as described above - OOo 3.3 uses A5 as paper size - but only if the page size is shorter than A5. That is the odd thing here.
I dont know whether it is really a duplicate, but I hope, this issue will be solved soon, as I cant use the actual version of OOo. If it was not solved I should get Word back...
Comment 14 micha-2010 2011-03-11 19:39:21 UTC
Created attachment 76086 [details]
OOo uses A5 in 3.2.1

On the right side you can see that it is not an user defined format, but A5 that OOo 3.2.1 chooses!
Comment 15 micha-2010 2011-03-11 21:41:57 UTC
Created attachment 76090 [details]
same document print dialoge in OOo 3.3
Comment 16 micha-2010 2011-03-12 09:16:19 UTC
Created attachment 76091 [details]
print dialog in OOo 3.2.1 with custom page size

This is the print dialog in OOo 3.2.1 when using a custom page size (in this example 14,8 x 20 cm, so a bit smaller than A5).
In OOo 3.3 the paper size "A5" is selected - so OOo recognizes that the printer knows this paper size. But only if the page size is smaller than A5 (with 14,8 x 20,9 the paper A5 is selected from OOo, with 14,8 x 21,0 A4 is selected).
So it is not like bug 113562, where a user defined paper size should be used that the printer does not know, but OOo doesnt assign the page size to the paper size of the printer correctly. Maybe it is only a arithmetic problem (cm to pixel or such a thing).
So please reopen this Bug as it is not a duplicate!!!
Comment 17 philipp.lohmann 2011-03-15 14:14:11 UTC
Indeed I found a place where paper matching from the driver on Mac failed. So this issue has connection to 113562 but is not exactly duplicate.
Comment 18 philipp.lohmann 2011-03-15 14:31:58 UTC
fixed that part in CWS vcl120. The other (when A5 is not reported by the driver like e.g. the Generic PostScript driver) will still be issue 113562.
Comment 19 h.ilter 2011-03-15 15:47:33 UTC
Verified with vcl120 = ok
Comment 20 Oliver-Rainer Wittmann 2012-06-13 12:22:26 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.