Issue 117339 - Crash when trying to import styles from .dotx file
Summary: Crash when trying to import styles from .dotx file
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 3.2
Hardware: All All
: P2 Normal (vote)
Target Milestone: 3.4.0
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-03-11 16:33 UTC by stefan.baltzer
Modified: 2012-06-20 02:18 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bugdoc (20.92 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.template)
2011-03-11 16:33 UTC, stefan.baltzer
no flags Details
Stack (from OOo 3.2 on Linux, crash report sent) (13.20 KB, text/plain)
2011-03-11 16:47 UTC, stefan.baltzer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description stefan.baltzer 2011-03-11 16:33:11 UTC
Created attachment 76082 [details]
Bugdoc

- New Writer document
 - Open "Styles and Formatting" box via <F11>
 - Via top right button, select "Load Styles..." from button menu
 - In upcoming diclog, click "From File"
 - Select format "MS Word 2007 xml"
 - Choose attached bugdoc (any such file will do)
-> Crash

Note: I looked into this with MBA. We can not import styles from .dotx files, this never worked. But in OOO 3.1.1 we did not crash. So the regression is since OOo 3.2.
Comment 1 stefan.baltzer 2011-03-11 16:47:18 UTC
Created attachment 76083 [details]
Stack (from OOo 3.2 on Linux, crash report sent)

Attaching stack
Comment 2 stefan.baltzer 2011-03-14 14:02:39 UTC
Correcting summary.
Comment 3 Oliver-Rainer Wittmann 2011-03-17 14:45:08 UTC
taken over
Comment 4 Oliver-Rainer Wittmann 2011-03-18 09:29:18 UTC
fixed in cws sw34bf05 - changed file:
/sw/source/ui/app/docsh2.cxx
change set http://hg.services.openoffice.org/cws/sw34bf05/rev/2c16677d6c72

one of part of the fix corrects the handling of the selected files for the loading of styles -> only files in own file format (ODF or OpenOffice.org XML File Format) are imported to load styles.
the other part of the fix adjust the filter list, provided in the file picker dialog.
Comment 5 openoffice 2011-03-18 11:45:08 UTC
fix reviewed by hbrinkm
Comment 6 Oliver-Rainer Wittmann 2011-03-21 09:41:37 UTC
od->sba: Checked in internal installation set of cws sw34bf05 - please verify.

Note for testing:
As the filter list has been adjusted in this dialog, you have to choose the Microsoft Word template file manually -> insert character '*' into the "file name" field and hit return; now you can choose the Microsoft Word template file in the file list.
Comment 7 michael.ruess 2011-03-23 13:41:24 UTC
Verified in CWS sw34bf05.
Comment 8 Oliver-Rainer Wittmann 2012-06-13 12:29:15 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 9 binguo 2012-06-20 02:18:16 UTC
Verified it on Aoo_Trunk_20120616.1800.1350879 and it does not reproduce, so close it as fixed.