Issue 117454 - old-style report doesn't work
Summary: old-style report doesn't work
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: DEV300m102
Hardware: PC Windows XP
: P3 Normal (vote)
Target Milestone: 3.4.0
Assignee: marc.neumann
QA Contact: issues@dba
Keywords: oooqa, regression
: 118169 (view as issue list)
Depends on:
Reported: 2011-03-18 12:35 UTC by eberlein
Modified: 2017-05-20 10:31 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

file to reproduce (11.67 KB, application/vnd.sun.xml.base)
2011-03-18 12:35 UTC, eberlein
no flags Details
png with error message (12.61 KB, image/png)
2011-03-18 12:37 UTC, eberlein
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description eberlein 2011-03-18 12:35:39 UTC
Created attachment 76143 [details]
file to reproduce

to reproduce:
- open the attached odb (created with 3.2.1) with m102, open the report, blind text is not replaced.
- close the doc and m102
- open the file with 3.2.1, the report is working
- close the file
- reopen it with m102
- it looks like it is opened read-only (Use wizard... is disabled)
- try to open the wizard, you will get a nice message (attached)
Comment 1 eberlein 2011-03-18 12:37:19 UTC
Created attachment 76144 [details]
png with error message
Comment 2 eberlein 2011-03-18 12:51:26 UTC
Remembering attachment 76113 [details] in issue 116215 ? ;)
Comment 3 r4zoli 2011-03-18 13:33:52 UTC
I tested on win7 and I can confirm it.
No data in report, if I run in DEV300m102.
If I run report in OOo 3.3 the report created correctly.

It seems to me it is a regression.

I tested with cws dba34 from qa-upload site, assertion:

Debug Output
Error: OControlImport::StartElement: illegal value property names!
From File D:/tools/o_dba34d/DEV300/ooo/xmloff/source/forms/elementimport.cxx at Line 893
Abort ? (Yes=abort / No=ignore / Cancel=core dump)
Igen   Nem   Mégse   

The "old" report builder changed in cws dba34d when solved bug 98163.

I retest it after dba34d integration.
Comment 4 r4zoli 2011-03-18 13:35:46 UTC
I forget to mention that the file corruption not happened on win7, only report created without data.
Comment 5 Frank Schönheit 2011-03-21 11:47:44 UTC
can't reproduce the file corruption - what you describe sounds like your OOo 3.2.1 still has the file locked, so m102 cannot open it. (not sure we already have an issue for this stupid error message.)

However, can reproduce the old-style reports not working anymore. Grabbing.
Comment 6 Frank Schönheit 2011-03-21 12:01:47 UTC
The report won't work anymore 'cause the values of the hidden controls are improperly imported. This was fixed in the course of fixing bug 98163. Unfortunately, another bug was introduced with this fix, namely the attempt to read a hidden control "Sorting", which doesn't exist in older reports, which breaks.
Going to fix this second bug in CWS fs34b.
Comment 7 Frank Schönheit 2011-03-22 19:09:48 UTC
fixed in CWS fs34b
Comment 8 Frank Schönheit 2011-03-29 08:25:33 UTC
fs->msc: please verify in CWS fs34b
Comment 9 marc.neumann 2011-03-30 11:56:31 UTC
verified in cws fs34b
Comment 10 r4zoli 2011-06-13 13:41:52 UTC
*** Issue 118169 has been marked as a duplicate of this issue. ***
Comment 11 Oliver-Rainer Wittmann 2012-06-13 12:28:21 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.