Issue 117462 - "Linked to file" OLE Calc sheet does not behave correctly when inserted more than once.
Summary: "Linked to file" OLE Calc sheet does not behave correctly when inserted more ...
Status: CLOSED DUPLICATE of issue 64202
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.2.1 RC2
Hardware: PC Windows XP
: P3 Normal (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 18:10 UTC by sztejkat
Modified: 2012-06-13 12:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description sztejkat 2011-03-18 18:10:18 UTC
1. Steps to reproduce
  - create new Calc document;
  - fill at least two cells in it with different content;
  - save it;
  - close Calc;
  - open new writer document;
  - insert OLE linked object, as "create from file" and "link to file" pointing to saved Calc document;
  - do it again. Now you have two views of the same sheet.
  - double click on the first one and adjust view are so that only one of filled cells is visible;
  - click somewhere else to stop editing;
  - double click on the second document. Observe what is now visible here;
  - click somewhere else to stop editing;
  - double click on the second one and adjust view are so that both cells are visible;
  - click somewhere else to stop editing;
  - go back to editing first inserted view and observe how it moved and re-sized;
  - close writer;
  - open Calc document;
  - fill some far off cell;
  - save;
  - open Writer document and observe what happen to views.

2. Current behavior:
 - Adjusting size or a visible part of sheet of any of views affects all others;
 - Any change to inserted and linked Calc document made through Calc will break settings of what is visible in a Writer document;
 - It seems that all linked object share the same viewport description. Viewport description seems to be stored in Calc document not in Writer. All linked views do share:
     - visible origin;
     - visible sheet;
     - number of visible rows and columns;
 - change to Calc document content made in one view do not propagate to other views.


2.Expected behavior:
 - each inserted linked to file object should have stored own viewport parameters in Writer file. Accessing linked sheet source file in Calc or via other inserted view must NOT change other views. Currently accessing document in Calc moves all inserted views in all Writer documents when links are updated (what means - on open and when one is willing to see changes made);
 - update made in one of linked views should trigger "Update link" event on all other views linking to the same document. Currently editing in one view requires double click or manual update to see changes propagation. This handles only one level of dependency but should be helpful in most cases and easy to do;
 - it would be nice to have "lock viewport" function to disallow users of document to move it. Similar as we have "protect cell", "protected paragraphs", "protected sections";


4. Background

  In effect one can't have a large sheet with complex calculation embedded as a part of an interactive Writer document. 
 
 This kind of operation was needed by me to create a  "Guide & Report from an Experiment". This kind of document document is mainly a lot of text telling step-by-step how to perform experiment with numerous places to be filled by an employee doing actual experiment. Values used in calculations in each step do depend on values entered earlier. 
 
 Finally I was forced to move to Calc and loose a lot of esthetic functionality. For example nice headers, save & print time tracking, table of content, styles in text, footnotes.

  Level of math complexity needed in such a report is far off from Writer own capabilities. 
 
  Level of esthetic required for printed reports is difficult to achieve in Calc. Or at least much more time consuming.

5.Workaround attempts:
 - Attempt to go around on Linux test with sym and hard links does not help;
 - Attempt to go around on Windows with "create link" .lnk file do not work;

Especially hard link failure strongly suggests that viewport parameters are stored inside a Calc document instead of inside a Writer. This is UNACCEPTABLE even for a single view per linked sheet.

- End of bug report -

Thanks for a great tool! I do really appreciate the effort & time You guys have put in OpenOffice to make it work as well as it does. It is well above 8 years now since I needed to use another office program!

Regards,
  Tomasz Sztejka.
Comment 1 eric.savary 2011-03-18 18:37:49 UTC
Same root cause as Bug 64202: One File = 1 View. Ole objects cannot sore different view.

Also not a Writer specific problem: the same happens with a Draw OLE in Calc.

*** This issue has been marked as a duplicate of issue 64202 ***
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:25:27 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.