Issue 117523 - extensions: OLE: broken SAFEARRAY VType
Summary: extensions: OLE: broken SAFEARRAY VType
Status: CLOSED DUPLICATE of issue 117010
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.3
Hardware: PC Windows XP
: P3 Normal (vote)
Target Milestone: ---
Assignee: joachim.lingner
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-23 16:50 UTC by jokusoftware
Modified: 2013-08-07 15:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jokusoftware 2011-03-23 16:50:28 UTC
After changeset 27974ced5167, a call to createUnoSequenceWrapper() in 
/extensions/source/ole/unoconvertsionsutilities.hxx, line 788, method:
template<class T> void UnoConversionUtilities<T>::anyToVariant(VARIANT* pVariant, const Any& rAny)
returns invalid data. 

The array element type is not returned properly anymore. The VT_ARRAY | VT_VARIANT is returned even if the SAFEARRAY contains completely different type.

This completely breaks OLE compatiblity for methods returning ARRAYs. It can be reproduced even on getAvailableServiceNames() method of XMultiServiceFactory of the com::sun::star::ServiceManager object instance.
Comment 1 Oliver Brinzing 2011-03-24 12:19:23 UTC
duplicate of http://openoffice.org/bugzilla/show_bug.cgi?id=117010 ?
Comment 2 Olaf Felka 2011-04-07 09:20:36 UTC
@ jl: Is this something for you?
Comment 3 joachim.lingner 2011-04-07 09:31:06 UTC
Yes, it is a duplicate of issue 117010
Comment 4 joachim.lingner 2011-04-07 09:31:46 UTC
.

*** This issue has been marked as a duplicate of issue 117010 ***
Comment 5 joachim.lingner 2011-04-07 09:32:24 UTC
.
Comment 6 Oliver-Rainer Wittmann 2012-06-13 12:23:06 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.