Issue 117597 - [sw] crash in undo on solaris
Summary: [sw] crash in undo on solaris
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m104
Hardware: All Solaris
: P2 Normal (vote)
Target Milestone: 3.4.0
Assignee: mst.ooo
QA Contact: issues@sw
URL:
Keywords: regression
: 117622 (view as issue list)
Depends on:
Blocks:
 
Reported: 2011-03-29 15:13 UTC by mst.ooo
Modified: 2012-06-13 12:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mst.ooo 2011-03-29 15:13:40 UTC
only on solaris:
current DEV300 OOo crashes in Undo with a linker error message:
ld.so.1: soffice.bin: fatal: relocation error:
 ... libswsi.so ... referenced symbol not found

reason is that the declaration and definition of the offending symbol
differ in parameter constness, and SunC++ has the bug that it
mangles parameter constness into the symbol.

what is surprising about this is that the library linked at all;
iirc the linker used to complain about this kind of thing.
Comment 1 mst.ooo 2011-03-30 10:02:43 UTC
fixed in CWS solaris11
http://hg.services.openoffice.org/hg/cws/solaris11/rev/7acea158da84
Comment 2 mst.ooo 2011-03-30 10:05:02 UTC
due to the fix for issue 107606 (which is really the root cause for this)
the inconsistent parameter constness now causes linking of libsw to fail.
Comment 3 michael.ruess 2011-03-31 10:48:29 UTC
*** Issue 117622 has been marked as a duplicate of this issue. ***
Comment 4 Oliver-Rainer Wittmann 2012-06-13 12:23:20 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.