Issue 117779 - OOo 3.3 removes MSVCR90.dll from path
Summary: OOo 3.3 removes MSVCR90.dll from path
Status: CLOSED DUPLICATE of issue 116035
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: OOo 3.3
Hardware: PC Windows 2000
: P3 Normal (vote)
Target Milestone: ---
Assignee: Olaf Felka
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-08 17:09 UTC by bobt98
Modified: 2012-06-13 12:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bobt98 2011-04-08 17:09:05 UTC
OS Windows 2000 Sp4
no C++
Windows Installer. V 3.01.4000.1823
OOo 3.2 also on system (this problem not seen)
issue similar to bug 116035, but more damaging.

Description:

1.Fresh install OOo 3.3.0, build 9567
2.Installation completed.
3.reboot
4.after OS loaded, the following error messages popped up on the GUI:

quickstart.exe - Unable To Locate DLL
---------------------------
The dynamic link library MSVCR90.dll could not be found in the specified path D:\Program Files\OpenOffice.org3\program;.;C:\WINNT\system32;C:\WINNT\system;C:\WINNT;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\Intel\DMIX. 
---------------------------

avastUI.exe - Unable To Locate DLL
---------------------------
The dynamic link library MSVCR90.dll could not be found in the specified path 
C:\PROGRA~1\ALWILS~1\Avast5;.;C:\WINNT\system32;C:\WINNT\system;C:\WINNT;C:\Program Files\AlwilSoftware\Avast5;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\Intel\DMIX. 
---------------------------

5. searched system for file MSVCR90.dll
6. result: file not found
7. uninstalled Avast Anti-virus.
8. rebooted
9. 1st popup error returned
10. reinstalled Avast.
11. reboot

Results: on loading OS, no longer received popup of MSVCR90.dll missing. OOo and Avast now work.

12. re-checked for MSVCR90.dll. Found it in:
C:\WINNT\system32
C:\WINNT\winsxs\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.1_x-ww_6f74963e
C:\WINNT\winsxs\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_d495ac4e

Conclusion: 
unlike OOo3.2, the install of OOo 3.30 removed MSVCR90.dll from folders in the system path which held the file.  This caused other programs which use the dll to fail.  Reinstalling a program which contained the dll restored it and the failed programs now work.

I would rank this with a high priority since it breaks other programs.
Comment 1 Olaf Felka 2011-04-11 05:40:30 UTC
known problem

*** This issue has been marked as a duplicate of issue 116035 ***
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:23:43 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.