Issue 117807 - Certain Fonts Fail To Export To PDF
Summary: Certain Fonts Fail To Export To PDF
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.3
Hardware: PC Linux, all
: P3 Normal (vote)
Target Milestone: 3.4.0
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-04-11 13:09 UTC by drichard
Modified: 2012-06-20 02:40 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The source document, with Bitstream Charter Font (8.02 KB, application/vnd.oasis.opendocument.text)
2011-04-11 13:10 UTC, drichard
no flags Details
The resulting PDF file (43.69 KB, application/pdf)
2011-04-11 13:10 UTC, drichard
no flags Details
Fails when not PDF/A-1a too (36.69 KB, application/pdf)
2011-04-11 13:12 UTC, drichard
no flags Details
The error that Acrobat Reader Displays (58.02 KB, image/png)
2011-04-11 13:14 UTC, drichard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drichard 2011-04-11 13:09:28 UTC
Since we upgraded to 3.3, we have been getting periodic support calls concerning problems exporting to PDF.   It turns out this issue is related to the font used.  I have been able to easily replicate the issue with "Bitstream Charter".  I created a one line documented in this font, exported it to PDF and then Acrobat Reader is unable to display the document and reports:

"Cannot extract the embedded font 'CharterBT-Roman'.  Sme characters may not display or print correctly".

It then comes up in non-displayable format.  We have a good amount of documents that are sent to outside contacts and are having this problem.  The users are having to change the fonts in all of their documents.  

Uploading my work files.
Comment 1 drichard 2011-04-11 13:10:10 UTC
Created attachment 76345 [details]
The source document, with Bitstream Charter Font
Comment 2 drichard 2011-04-11 13:10:36 UTC
Created attachment 76346 [details]
The resulting PDF file
Comment 3 drichard 2011-04-11 13:12:45 UTC
Created attachment 76347 [details]
Fails when not PDF/A-1a too
Comment 4 drichard 2011-04-11 13:14:52 UTC
Created attachment 76348 [details]
The error that Acrobat Reader Displays
Comment 5 philipp.lohmann 2011-04-14 15:49:11 UTC
sigh, an off by one error during type1 pfb font export

fixed in CWS ooo34gsl02
Comment 6 philipp.lohmann 2011-04-15 09:26:11 UTC
please verify in CWS ooo34gsl02
Comment 7 h.ilter 2011-04-15 09:43:57 UTC
Verified with cws ooo34gsl02 = ok
Comment 8 Oliver-Rainer Wittmann 2012-06-13 12:22:17 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 9 binguo 2012-06-20 02:40:56 UTC
Verified it on Aoo_Trunk_20120616.1800.1350879 and it does not reproduce, so close it as fixed.