Issue 117867 - crash on redo of "paste clipboard" action
Summary: crash on redo of "paste clipboard" action
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m99
Hardware: All All
: P2 Normal (vote)
Target Milestone: 3.4.0
Assignee: mst.ooo
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-04-15 12:37 UTC by Oliver-Rainer Wittmann
Modified: 2012-06-18 07:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver-Rainer Wittmann 2011-04-15 12:37:39 UTC
follow-up of issue 117831:
- perform actions described in issue 117831 (since DEV300m103 fix for issue 117863 is needed)
- now perform a redo
--> crash

crash occurs since DEV300m99, DEV300m98 works fine.
Comment 1 mst.ooo 2011-04-27 14:23:36 UTC
sorry, cannot reproduce this.
i've built sw34bf06 on solaris and tried showing & hiding sections,
then undo/redo, but no crash.
only thing that's bad is the navigator flickers when sections are hidden.

@od:
please provide more details, perhaps a stack trace :)
Comment 2 Oliver-Rainer Wittmann 2011-05-03 11:51:57 UTC
od->mst: As shown in person the crash still occurs as described:
- new Writer document
- insert some text
- insert a section with some
- copy all
- second new Writer document
- paste into second new Writer document
- undo
- redo
--> crash.
Comment 3 mst.ooo 2011-05-04 12:27:10 UTC
of course, if you look at the right issue and not the wrong one,
then it is easy to reproduce :)

actually you don't even need a section, inserting just 3 paragraphs,
then undo+redo is enough.

reason is that i've wrongly adapted the SwUndoInserts::RedoImpl
method to use the indexes stored in the SwUndRng base class,
which it hasn't done before (they should be used only in UndoImpl)
and which causes the crash.

fixed in CWS sw34bf06
http://hg.services.openoffice.org/hg/cws/sw34bf06/rev/f573e7e8e68c
Comment 4 Oliver-Rainer Wittmann 2012-06-13 12:22:06 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 5 binguo 2012-06-18 07:12:07 UTC
Verified it on Aoo_Trunk_20120616.1800.1350879 and it does not reproduce, No crash, so close it as fixed.