Issue 117966 - Duplicating slides between presentations does not work
Summary: Duplicating slides between presentations does not work
Status: CLOSED DUPLICATE of issue 116668
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.3
Hardware: PC Windows Vista
: P3 Normal (vote)
Target Milestone: ---
Assignee: graphicsneedsconfirm
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 16:22 UTC by freemans
Modified: 2012-08-31 05:50 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
ODP Presentation (902.63 KB, application/vnd.oasis.opendocument.presentation)
2011-04-30 16:22 UTC, freemans
no flags Details
screenshot of last slides of presentation before copied (488.77 KB, image/png)
2011-05-28 22:46 UTC, airez
no flags Details
screenshot of last slides of presentation after copying (488.77 KB, image/png)
2011-05-28 22:49 UTC, airez
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description freemans 2011-04-30 16:22:32 UTC
Created attachment 76469 [details]
ODP Presentation

I really want to like Impress.  I really do.  But, it's just not working.  I create a presentation and save it and then open another presentation and try to insert the first presentation into the second and it doesn't work.  Well, it works, but it's not right.  My text formatting is all off.  I have background colors I didn't ask for.  It's all just out of wack.  It does the same thing if I try to drag-drop from the first presentation to the second.  It also does the same thing if I try to import this into a blank, brand new presentation.

I know programming is hard, but I would have thought that copy/paste would have been one of the easier functions.  This software is already slower than PowerPoint, which causes me some grief, but I'm willing to endure that if it will only work.

I am attaching the second presentation to this bug request.

The first is Serie_II_Pedro.odp -- this is a presentation of a sermon.  If you try and add this to a new presentation, the last slides are all screwed up (blue background, misformatted, etc).
Comment 1 freemans 2011-04-30 16:23:55 UTC
One thought:  The only thing I can figure is that I'm using a custom style in those text boxes: Normal_II_Pedro.  But, I would think this software would be intelligent enough to copy the styles....
Comment 2 freemans 2011-04-30 16:27:09 UTC
Okay.  I have a workaround.  I went to the new presentation and created the style first and then it imported fine.  Still a bug though.  Should import all necessary styles to make the presentation appear correctly.
Comment 3 Regina Henschel 2011-04-30 16:48:27 UTC
This seems to describe a similar problem as in issue 116668. Please read comment #13 there for more information on including styles when importing.
Comment 4 airez 2011-05-28 22:41:39 UTC
Summary
Issue described by original reporter does exist in OOo-dev 3.4.0. DEV300m106 (Build:9582) 

Environment
OpenOffice version: OOo-dev 3.4.0. DEV300m106 (Build:9582) 
Operating System: Windows 7 Professional 64bit Operating System 
Lenovo ThinkPad T410

Data
I used two presentations for my tests, one provided by original reporter (Presentation 1) and second one I created for testing purposes with few slides (Presentation 2) Those presentations have different formatting from each other.

Steps to reproduce
These are the tests I ran based on the original reporters comments:

1. Copy and paste one presentation to another
Steps:
1. open both presentations (Presentation 1 and Presentation 2)
2. Select all slides from Presentation 1 and choose „copy“ 
3. Focus on Presentation 2
4. Select Paste

Actual Result:  After the dialog  "The format of the new pages will be adapted. Do you want to adjust the objects too?" All slides are copied to Presentation 2, some of the slides have blue background that was not there before.

2. Drag and drop few slides from one presentation to another
Steps:
1. Open Presentation 1 and Presentation 2
2. Select few slides from Presentation 1
3. Drag and drop those slides to presentation 2

Result: Selected slides are copied to Presentation 2 (if the selection included slides from the end of Presentation 1, those slides have blue background)

3. Copy and paste presentation to new blank presentation
Steps: 
1. open Presentation 1 and create a new presentation 
2. Select all slides from Presentation 1 and choose „copy“ 
3. Focus on new presentation
4. Select Paste

Actual Result:  After the dialog "The format of the new pages will be adapted. Do you want to adjust the objects too?", all slides are copied to Presentation 2.  Some of the slides have a blue background.  This was not there before. 

Follow-up tests:
1. Copy only the last slides that were changed during the copy-paste of the entire presentation
Steps:
1. open Presentation 1 and create a new presentation 
2. Select only slides that were changed when entire presentation was copied from Presentation 1 and choose „copy“ 
3. Focus on new presentation
4. Select Paste

Actual Result:  After the dialog  "The format of the new pages will be adapted. Do you want to adjust the objects too?" all slides are copied to new presentation.  Slides have a blue background.  This was not there before. 

2. copy only one of the slides that were changed during copy-paste of entire presentation 
Steps:  
1. open Presentation 1 and create a new presentation 
2. Select a slide from Presentation 1  that and choose „copy“ 
3. Focus on new presentation
4. Select Paste

Actual Result:  After the dialog "The format of the new pages will be adapted. Do you want to adjust the objects too?" all slides are copied to the new presentation.  Slides have  a blue background. This was not there before.
Comment 5 airez 2011-05-28 22:46:17 UTC
Created attachment 76564 [details]
screenshot of last slides of presentation before copied

Added before-copy screenshot of slides that are having blue background after copy
Comment 6 airez 2011-05-28 22:49:51 UTC
Created attachment 76565 [details]
screenshot of last slides of presentation after copying
Comment 7 Oliver-Rainer Wittmann 2012-06-13 12:18:55 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 8 louqle 2012-08-31 05:50:25 UTC
dup

*** This issue has been marked as a duplicate of issue 116668 ***
Comment 9 louqle 2012-08-31 05:50:48 UTC
close as dup