Issue 118008 - AutoFilter with a Standard Filter applied - fill down values with the fill handle across rows hidden by the filter not only fills the cells in the visible rows but also fills the cells in the hidden rows as well
Summary: AutoFilter with a Standard Filter applied - fill down values with the fill ha...
Status: CLOSED DUPLICATE of issue 89232
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 3.3
Hardware: PC Windows NT
: P3 Normal (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
: 125031 (view as issue list)
Depends on:
Blocks:
 
Reported: 2011-05-12 21:10 UTC by vavra_milan
Modified: 2014-06-02 19:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description vavra_milan 2011-05-12 21:10:38 UTC
AutoFilter with a Standard Filter applied - fill down values with the fill handle across rows hidden by the filter not only fills the cells in the visible rows but also fills the cells in the hidden rows as well

In a table with AutoFilter and a Standard Filter applied,
if you try to fill down cells with the fill handle across rows hidden by the Standard Filter, not only will the cells in the visible rows be filled, but also cells in the hidden rows will be filled.

For example:
Let's have the following simple table:

 |A|B|
1|a|b|
2|1| |
3|2| |
4|1| |
5|2| |
6|1| |

Let's select it, A1:B6, and
apply AutoFilter to it by selecting Data, Filter, AutoFilter from the menu.
Then let's apply Standard Filter on column A to show rows that equal 2.

The result will look like this:

 |A|B|
1|a|b|
3|2| |
5|2| |


Now click B3 and enter x.

 |A|B|
1|a|b|
3|2|x|
5|2| |

Click B3 to select it.

Drag the fill handle on B3 to B5.

 |A|B|
1|a|b|
3|2|x|
5|2|x|

Cancel the Standard Filter on column A.

The result looks like this:

 |A|B|
1|a|b|
2|1| |
3|2|x|
4|1|x|
5|2|x|
6|1| |

Notice that B4 was filled.

The expected result would be:
 |A|B|
1|a|b|
2|1| |
3|2|x|
4|1| |
5|2|x|
6|1| |

where only the cells in rows visible at the time the fill handle was used
would be filled.
Comment 1 niklas.nebel 2011-05-13 12:33:43 UTC
This behavior is already changed in OOo 3.4 beta, see issue 89232 and http://blogs.oracle.com/GullFOSS/entry/changed_behavior_of_autofill_when.

*** This issue has been marked as a duplicate of issue 89232 ***
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:25:30 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 3 Marcus 2014-06-02 19:02:00 UTC
*** Issue 125031 has been marked as a duplicate of this issue. ***