Issue 118239 - A general error occurred while accessing your central configuration.
Summary: A general error occurred while accessing your central configuration.
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: version58
Hardware: All All
: P3 Normal (vote)
Target Milestone: OOo 3.3
Assignee: AOO issues mailing list
QA Contact:
Keywords: needhelp
Depends on:
Reported: 2011-07-03 22:16 UTC by brianfristensky
Modified: 2014-11-22 23:26 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description brianfristensky 2011-07-03 22:16:00 UTC
Summary: When trying to start any OO component (oowriter, ooimpress, oocalc etc.) a message pops up

OpenOffice.org3.3 - Fatal Error
The application cannot be started. 
A general error occurred while accessing your central configuration.

This is the only symptom. When trying to launch the application from the Linux command line, no messages of any kind are seen, aside from the popup.

System: Fedora 14 x86_64, updated using yum update.
RPMs include the version information 1:3.3.0-20.6.fc14 (x86_64)

Additional comments:

1. This problem has been widely reported on various news groups, for both Windows and Linux. It appears to be an ongoing problem both in OO3.3, AND in LibreOffice 3.3 and 3.4. See bug 33475 at

In fact, when OO3.3 stopped working, I installed LibreOffice 3.4 (stable), and got precisely the same error message. Neither OO no LO works on my account, at present.

2. On Linux, removing, respectively, ~/ or ~/.libreoffice does no good. New directories of the same names get created, and the same error message pops up.

3. This bug happens on an account by account basis. That is, it happens to each
user on the system, independently, after one or more uses of OO or LO. An
important point here is that once either program is broken, both are broken.
If I create a new user account, the first time I try to use OO or LO, the
program works. After one or more launches, suddenly both no longer work at all. 

4. This is an old and widespread bug. If you google the error message, you see
numerous people complaining about this problem for at least a year, with both
OpenOffice and LibreOffice. 

5. I have not installed any extensions. 

6. I see the bug running on GNOME, KDE, and LXDE desktops, same machine, same

7. I have checked /var/log/secure, /var/log/messages, with no messages recorded
at the time OO or LO was launched.

So the status is, on my system, I can run neither OO nor LO work at all. Zilch!

Perhaps a good approach would be for someone with access to the source code to
grep the error message and see which part of the code generates this message.
Comment 1 Oliver-Rainer Wittmann 2012-06-13 12:17:12 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 2 mzimen 2012-06-19 11:02:19 UTC
The same issues with debian:

   libreoffice                          1:3.4.6-2
Comment 3 Edwin Sharp 2014-01-26 19:14:13 UTC
Can not reproduce.
AOO410m1(Build:9750)  -  Rev. 1557669
2014-01-14_04:11:13 - Rev. 1557927
Comment 4 billp 2014-11-22 23:26:54 UTC
A user has reported on the OpenOffice Community Forum that setting a DATA environment variable will cause this error in Windows 7 and Windows XP. After removing the DATA environment variable, AOO starts normally. I have reproduced the error in Windows 8.1.